RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter #1
I noticed yesterday that my brake lights were not working! I dont know how long they have been like that but it scares the crap out of me that I was driving around like that, I know they were fine a few days ago for sure. I have a somewhat limited knowledge of the brake light wiring on a RR so I've only checked what I could figure out.

Removed brake light switch at pedal and cleaned and tested it, switch is working fine.
Jumped the two leads going to the brake light switch just in case and no luck.
Checked the fuses for all the rear lights and those are fine.

I have a trailer brake controller professionally installed under the dash by the prev. owner and it has a big button on it to send a signal to the brake lights, trailer, etc. When that button is pressed the brake lights do come on. I have been using that button every time I apply the brakes just to get to work and back since yesterday but I will not keep driving it like this, it's just too dangerous.

Does anyone have any idea what I could check that may be a likely culprit? I have the good workshop manuals at home and the wiring diagrams are a big help but it's still a pain figuring out this kind of thing.
Thanks so much for any suggestions!
 

·
Registered
Joined
·
1,395 Posts
Still having problems...?
 

·
Registered
Joined
·
59 Posts
Discussion Starter #3
Yeah, Still not working correctly... Both switches at the brake pedal check out ok but can not seem to track down the fault!
After a couple hours of screwing around I just did a little cheesy repair by wiring in the the leads from the brake light switch to the ones on my trailer brake controller haha... I know its a little too ghetto to be doing this on a range rover but I had a BBQ to go to this weekend. So thanks to my lame temporary repair my brake lights are working for now but I would really like to fix them correctly as soon as possible.
 

·
Registered
Joined
·
1,395 Posts
So are you getting power at the brake lights when the pedal is pressed?
 

·
Registered
Joined
·
59 Posts
Discussion Starter #5
I am now, but the power is coming from the wire harness for the trailer brake controller and going out of the brake pedal back to the wiring for the the trailer brakes. It works but I just didnt have the time to actually find where the fault was with the RR wiring. It seems like there is no power going to the brake light switch. Electrical meter/tester is broken so I havent been able to accurately check. So for now I press the brake pedal and the brake lights illuminate I just wish it were wired correctly :(
 
1 - 5 of 5 Posts
Top