Range Rovers Forum banner
1 - 15 of 15 Posts

·
Registered
2006-2009 Range Rover Sport
Joined
·
132 Posts
Discussion Starter · #1 ·
I have been using the iPhone 4 in my 2008 RRS S/C for the last 18 months with no problems. On Tuesday, I replaced my iPhone with a new Samsung Galaxy 3S, and am having problems with the device staying connected. What I am observing is that the phone is disconnecting, and reconnecting about every 90 seconds. Even when it is connected, my address book is not being transferred to the RRS.

I looked at the site that umberto has in the sticky at the top of the forum, and they only state that the Galaxy 2 is currently being reviewed. Since that phone has been out for some time, I think the data is a little out of date.

Anyone had a similar problem, and resolved it?
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
67 Posts
There's something wrong with your phone or the unit....I have galaxy s3 & a iphone 5 and they both work perfect in my 06 RRS S/C ...try resetting your phone..and when you turn your Bluetooth on make sure u don't turn on the option above discover my device.. I leave that option off cause there is a timer on that Wichita I believe is 90 seconds...hope this helps you out bro
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
132 Posts
Discussion Starter · #3 ·
I returned the last Samsung Galaxy S3, as it was not receiving calls, in addition to not syncing with the Range Rover Sport. I just received it's replacement and am seeing the same thing. It will connect once paired, then disconnect / connect every 30 seconds or so. Never had a problem with the iphone 4.

On a whim, I paired the phone and truck again, and this time did not allow the car access to the contact list. As it appears that when it's trying to load the contact list, that it disconnects. We will give it a try tomorrow when I leave for work.
 

·
Registered
Joined
·
1,175 Posts
I have a Galaxy 2 and always have to re-boot it every time if I want it paired to the Car. I know it's not the Phone because it pairs immediately every time in my wife's BMW.

My Bluetooth settings:

Bluetooth : Check

Visible: Check

Visible time-out: Never

Bluetooth Devices Paired:

BMW

Range Rover Sport.

I have even tried deleting my Phone from the RR and re-pairing (is that a new word)? several times.

Is it best to have the RR pair with the Phone, or pair the Phone with the RR? We have a choice.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,015 Posts
Jaguar27, why would you want your Bluetooth phone to be discoverable at all times? That must eat through your battery like crazy... Turn that timeout back on to the 2-minute default, having it discoverable all the time won't make any difference with your existing connections, which are already paired and should - in theory - reconnect to the phone automatically even when it's not visible.

On MY2009s and earlier, the pairing process is one-way only, phone needs to find to the car, can't do it the other way. FWIW, on both my 2006 RRS and 2013 LR4 - same as MY12+ RRS, I believe - my Droid Razr Maxx HD with Android 4.1 Jellybean pairs and downloads phonebooks fine automatically (but I can't get Bluetooth audio streaming to work on the LR4, even though "Media audio" is checked the Bluetooth connection shows "No media" after the phone's automatically connected to the car...)

PS: The Bluetooth connection to the Sport should be named "Land Rover" on your phone, not "Range Rover Sport". Meaning that, if you have manually renamed the connection you may want to change it back to the default. Not sure that would make an iota of difference, but Bluetooth is so finicky to begin with, you never know...

PPS: A few seconds after connecting for the very fist time to the car, your Android phone should inform you with a popup (or an icon in the message center on top of the screen) that Land Rover is requesting access to your phonebook (or something to that effect), make sure you also check the "Do not ask me every time" box before granting access, as that may be part of the problem.
 

·
Registered
Joined
·
1,175 Posts
PS: The Bluetooth connection to the Sport should be named "Land Rover" on your phone, not "Range Rover Sport". Meaning that, if you have manually renamed the connection you may want to change it back to the default. Not sure that would make an iota of difference, but Bluetooth is so finicky to begin with, you never know...

PPS: A few seconds after connecting for the very fist time to the car, your Android phone should inform you with a popup (or an icon in the message center on top of the screen) that Land Rover is requesting access to your phonebook (or something to that effect), make sure you also check the "Do not ask me every time" box before granting access, as that may be part of the problem.
Thank you very much!!

My Friend, who is actually the salesman who sold me the Car, set up my Phone as I was driving him to the Bank to pick the check up so I could take my RRS home, I don't think he configured it to "Range Rover Sport" from "Land Rover" I know I certainly didn't.

Next time I will pay attention to the "Access Address Book" to see if I have a "Don't ask again" option.

I also changed the Visible to 2 minutes on your advice.

Thanks again for your help, I will see what happens later when I go into work.
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
132 Posts
Discussion Starter · #9 ·
Not sure if I have something "odd" in my phone book. After trying to pair and un-pair multiple times, I was close to giving up. The phone would connect and disconnect every 30 seconds. I gave it one more try, and hit "cancel" when prompted to allow access to the address book, and the phone now, connects, and works fine. It does not have access to my phone contacts, but I can work around that for now.

For folks that have no problem with their Galaxy S3, are your contacts stored in the phone, or SIM card?
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
24 Posts
Hey guys,

I'm new to the forums and to the RRS. I've got a 06 RRS and so far I love it. Here's the kicker. I've got the Samsung S3 and have attempted to connect it many different times. Unfortunately I don't even get it to the point where it discovers the RRS. I do have blue tooth as I press the phone button and the display says "no phone fitted".

Anyone have any other ideas or suggestions on how I should try to pair them. I went from a 06 Lexus GS400 and the bluetooth option is by far one option which I really need.

Thanks in advance.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,015 Posts
The Bluetooth / PTI module was an option on MY06 RRS (except the Supercharged, where I believe it was standard), are you sure yours is fitted with it? Is there a latch for a cell phone cradle under the center armrest and dial / hang up paddles on the right side of the steering wheel? The "No phone fitted" message by itself is no indication you have the module, since the head unit is otherwise the same (the phone button is there even on models not fitted with PTI.)
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
24 Posts
Actually you may be right. I don't have any phone buttons on the steering wheels, unless I am missing something. Do you have any images of what that looks like. Also, there is no cradle thing in the armrest. When buying my RRS, I did see another one that did have that cradle thing in the arm rest. I guess that mean that other RRS had it and I don't.

This sucks .... bluetooth ear piece thingy it is from now.

Thanks Umberto... I think I am going to attempt a removal of the stock stereo and replacing with an aftermarket unit with bluetooth. Still doing some research on that.

Thanks again.
 

·
Registered
Joined
·
1 Posts
my galaxy s5 will not stay connected via bluetooth to my 2012 range rover sport for more than a few mins. I have installed & uninstalled several times I have tried pairing car to phone phone to car all to no avail
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top