RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have an 06 HSE. According the the paperwork and a VIN search, it is supposed t have Bluetooth (it does have navigation also). I cannot get my iPhone to pair. The "Land Rover" does not show up when I try to find it. Thoughts?
 

·
Administrator
Joined
·
27,834 Posts
Either it is not fitted or the module is dead. There are many existing threads on identifying the module at the rear of the vehicle and options for replacement... along with pairing difficulties. However if you are seeing it as an option then it may be time for a replacement.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
118 Posts
Open the access door on the left side of the trunk wall.

You should see what looks like a single disc CD player (that's your Nav data) and above that there should be a module that measures about four by three by two inches with a convex top.

That's your BT module. There's a single multipin connector to it.

If it's there but doesn't appear to work, don't waste your time with it.

Look for a used BT module from a 2010-on Range Rover and install that in it's place. After making a modified mount, you'll only need to connect two of the wires to the later module and the clarity of the 2010-on makes the $100-150 upgrade a better option than exchanging a like for like original.

Rob
 

·
Administrator
Joined
·
27,834 Posts
Yes Anvil, all of that is covered in previous posts and the other options available. Easily found when mentioned they exist.
 
1 - 5 of 5 Posts
Top