RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter #1
We seem to have solved the EAS problems on my 98 RR 4.6 (see my post "EAS : are we on the right track"), BUT a new gremlin has appeared. The gearbox fault message has come on , but the rovocom diagnostics has not registered this fault. The gear change from 1st to 2nd is now rough on acceleration and deceleration . I have read all the posts relating to this and battery/alternator testing appears in numerous posts, so we will check these readings.The auto electrician is convinced that the BECM is faulty as we have other elecrical gremlins (BOOK SYMBOL ON HEVAC COMING ON INTERMITTENTLY) , non starting (replaced crank sensor). Fuse box has been replaced.Temp sensor has been replaced.
Is there anything we should focus on when we remove and check the BECM?
Any advice will be appreciated.
i Will keep this post updated with any progress.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,851 Posts
Hi

Your gearbox has its own ECU and is not directly operated from the BECM. Your 4 speed gearbox has a bosch transmission controller and the transferbox ECU a borg warner ECU for changing from high to low and vice versa.

If you get gearbox fault message you have to look into the gearbox ECU for the fault and not in the BECM.

Regards

Jos
 

·
Registered
Joined
·
61 Posts
Gearbox Fault Message can also appear when the battery is giving a low voltage. As previous post the gearbox has its own ECU. Hevac does a self test every time you start the car, it cycles the blend motors so you may have one sticking your diagnostic tool can see which one and force outputs to check they are working OK. If its intermitant then its unlikely to be low refrigerant in the aircon but woth checking that too.
 

·
Registered
Joined
·
53 Posts
Discussion Starter #5
Thanks for the comments guys. I have just returned from the auto electricians with your comments and they will check the gearbox ecu and the other advice you guys gave. We realise that BECM surgery is a last resort and would hope that we solve this before that procedure.I have told the electricians if they have any technical queries i would forward them here for your valued advice.
Thanks again.Will keep u posted
 

·
Registered
Joined
·
53 Posts
Discussion Starter #6
Update. There was a bad connection between the gearbox ecu and and the gearbox wiring loom at the multiplug (so i'm told) and this has solved the problem of the rough gear change , without having to open the becm.Thanks for the advice. :D
Now to tackle the book symbol on the hevac. We will check aircon gas and if this is'nt the cause will check blend motors guided by the "sticky" on this forum.
Will keep you posted.
Thanks again.
 
1 - 6 of 6 Posts
Top