RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
215 Posts
Discussion Starter #1
I poking around the engine bay the other day and noticed that the cap covering the positive battery terminal was not installed. I'm assuming when the battery was replaced, someone just didn't install the cap correctly.

As I try to install it, I see it doesn't fit. My assumption is that I have to loosen or disconnect the black cable at the bottom of the terminal, reposition it so that the cap fits, and tighten it back up. But....I wanted to play it safe and ask first...I'm not sure what that cable does...and I know the rover is very finicky with electronics. Your assistance is greatly appreciated...or if someone can just pop a pic of what the terminal looks like with the cap installed....and a pic with the cap off...I'd appreciate it.

Thanks!

https://i48.photobucket.com/albums/f226/Caifanito/IMG-6954_zpswga1iurk.jpg






 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
1,953 Posts
wait 2 mins atleast after removing the key,
then disconnect the ground terminal,

then adjust the positive terminal wires,

then reconnect the ground.
Start the truck slowly turn the wheel left to right then back,
bounce off the stop dont hold it, the ABS lights should go off
then hold the roof button in the center till it opens but dont let it go, keep pressing till it clicks.
\ Then slide the switch forward and hold it till its closed, then let go,
This will reset the roof.
 
1 - 2 of 2 Posts
Top