RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
2007 full size RR with logic 7 HK stereo. I have lost sound from the subwoofer and rear door lower speakers only. Does the subwoofer amplifier power any of the other door speakers in the system other than the sub?
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
548 Posts
Same here
Waiting!!!!
I had always important issues than sub, still it is not working
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
111 Posts
It may be similar on the 2007, but on the 2004 it powers the front left and right channels and the sub. The other amplifier does the rear channels.

I describe some of the functionality in this video


 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Ok thanks, I ordered a new sub and amp and will replace and update the forum on what happens.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Well new subwoofer and amp did not correct the problem so I am thinking bad wiring somewhere at this point.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
Well thankfully the door speakers were just blown. I replaced them all with FOCAL 165AS components that have the 6.5" woofer. Now the only thing that is still inop is the subwoofer, still trying to figure it out.
 

Attachments

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
111 Posts
Nice. Were those Focal component drivers direct-fit compatible with the OEM Logic 7 drivers and system? Did you run any custom crossovers or just wire the drivers up and go?
 
1 - 7 of 7 Posts
Top