Range Rovers Forum banner

Apple CarPlay Headunit

2353 Views 3 Replies 1 Participant Last post by  meelaud
Hey there,

My 06 RRS has been in "phone mode" since I bought it a few weeks ago. I tried doing the battery reset (wire between the terminals) and tried using my iCarSoft diagnostic tool to clear all the radio related codes - but I'm still stuck in phone mode. I was thinking about getting a junkyard OEM unit - but the prices seem a bit high for an old unit imho.

My other car has a Apple CarPlay unit and it spoils me. Hell, every time I rent a car these days - it has that.

I received a quote from my local Best Buy (~$850 for a Pioneer Apple CarPlay double din head unit with all the parts needed for install) who claims to have done this to other newer Land Rovers - but I'm still skeptical since this car has a mile of cables running inside of it. I'm totally fine losing the top nav screen too as the touch capacitor crapped out too. I don't have the rear entertainment package either if that makes a difference.

I searched and saw folks had some success in the past, but I just want to see if anyone recently has done this.
1 - 4 of 4 Posts
Update: pulled the head unit and had temporary success pulling and reconnecting the MOST cable...but it reverted to phone mode after a few minutes. Ugh

I have a used OEM unit from an lr3 coming in for the time being...I’m assuming it’s the same as the one in the RRS. Please correct me if I’m wrong.
Just talking out loud: but soon after placing the order for the LR3 head unit, I noticed the number on the faceplate is 6CD-465 - but the RRS ones say 6CD-565. I tried doing a search and found nada, ended up calling my Land Rover dealer and they said that the head units are different. thankfully i was able to cancel the LR3 order and found a RRS one. if the new 565 one is a dud, then I'll reconsider an Apple CarPlay unit.
rolled the dice on an unknown condition $75 head unit from ebay. upon taking the old one out completely, i saw some sort of coffee/coke stain all over the back of the unit...could explain why it bit the dust. hooked the new one up and voila - radio works! guess ill table the apple carplay business until later
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.