RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Registered
2019-2021 Range Rover Classic
Joined
·
2 Posts
Discussion Starter #1 (Edited by Moderator)
Wondering if I'm the only one with this, or if there's a work-around that doesn't involve a shutdown/restart.

2019 Range Rover, software UTD per the OTA in-dash updater. Apple iPhone 8Plus, also UTD.

CarPlay works fine (though the computer/display is bog slow) when it's plugged in before or after a normal startup. When I use the factory RemoteStart through the RR app, the display recognizes there's a phone that's CarPlay ready plugged in but won't let me use it. (I've tried this several times, it's not a one-off). I have been able to make it work by shutting the vehicle completely down and restarting, and it works normally, but that's a clunky workaround.

Carplay.jpg

Note the far right pane indicates it 'sees' CarPlay, and the alert in the center is what I get when I hit the 'play' in that pane. (Yes, I like that song).

Anyone else have this?
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
293 Posts
There is a workaround.
The new update 18D is supposed to fix this issue.

Start car with remote app.
Key point- Before you go to the car, stop the car with the app (do not unlock and get into your car).
Proceed into your car as normal and your apple car play will/should work.



Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
245 Posts
New update fixes it, and you don't have to shut your car off for it to work.
 

·
Registered
2019-2021 Range Rover Classic
Joined
·
2 Posts
Discussion Starter #7
Good news, thanks! I've tried the OTA update and I get nothing, is this a service center item?
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
29 Posts
I can confirm 18D does definitely fix it. This doesn’t get updated OTA though yet, you will have to convince your dealer to do it.

I had to really fight with my dealer to convince them to update the car, even showing them the 18D release notes posted on this forum as they didn’t believe me it was a bug!
 

·
Registered
Joined
·
1,006 Posts
I can confirm 18D does definitely fix it. This doesn’t get updated OTA though yet, you will have to convince your dealer to do it.


I had to really fight with my dealer to convince them to update the car, even showing them the 18D release notes posted on this forum as they didn’t believe me it was a bug!

I go in telling them my cameras don't always work and map doesn't always show on cluster That usually always triggers a software update
 
1 - 9 of 9 Posts
Top