RangeRovers.net Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I've seen this problem on so many forums but not on this one yet. I was wondering if anyone has seen this issue with receiving calls:

1) Apple Car Play in New Range Rover 2019 (latest software update)
2) Iphone X latest software 12.2
3) Apple Car play connects and I can place calls with audio working
4) Apple Car play receiving calls DOES NOT work and I cannot hear the other person
5) I have to then use the speaker on my iPhone and use that manually bypassing the car system
6) If the apple car play doesn't connect and the bluetooth only works, there is no issue
7) I can't charge my phone and not connect to apple car play.

Any help?
 

·
Registered
2016-2018 Range Rover MkIV / L405
Joined
·
293 Posts
Most the issues I’ve had with CarPlay are my phone screwing up or a bad cable.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Thank you for the feedback.

I've tried everything apple say:

Turn on Siri, latest software, try different USB port and official cable
 

·
Premium Member
Joined
·
1,829 Posts
There is an article on Topix describing some of these issues making an assumption that the bug is on Apple's side. I'm having similar issues since the 12.2 iOS update. I tend to agree w Land Rover, it smells like iphone problems.
On a related note, my wife and I switched to facetime audio calls when either of us are in a car, because she experiences the same issues, although she's on an iphone 7.
facetime works all the time.

We do not have problems with connecting to the car and charging, though.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #5
Thank you for the reply.

That's really annoying that it's iOS. Is there any way to turn the Apple Car Play off without disconnecting it?
 

·
Premium Member
Joined
·
1,829 Posts
go to Settings/All settings/Software Update

FWIW my Range Rover has 19A2, and the Sport has 19A
 

·
Registered
2019-2021 Range Rover MkIV / L405
Joined
·
29 Posts
Interestingly for me this problem coincided with the upgrade to 19A, I didn’t have it on 18D (and I’m not on 19A2 yet)

i found that unpairing the phone via Bluetooth helped, but didn’t fix it completely.

I have also noticed that unlocking the phone once the call is answered does seem to fix it though and you get two way audio!

Incredibly frustrating as CarPlay actually worked really well for a bit!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #11
I can confirm I still have 18D (will go to the garage to ask for 19A or whatever else is there). So frustrating! I just want to disable CarPlay somehow
 

·
Premium Member
Joined
·
1,829 Posts
I can confirm I still have 18D (will go to the garage to ask for 19A or whatever else is there). So frustrating! I just want to disable CarPlay somehow
You can go to All Settings/Connectivity. Scroll down to Apple Devices (or whatever) and tap on it. You can disable CarPlay autostart there. You can then still launch CarPlay from the touchscreen if you want to.
 
1 - 14 of 14 Posts
Top