RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2013-2015 Range Rover MkIII / L322
Joined
·
2 Posts
Discussion Starter #1
IMG_1643[1].jpg

Hello, I recently incurred this problem after purchasing my Range Rover Vogue Autobiography L322 4.4 L V8 TDV8 diesel. The Range rover logo is constantly shown when the key is detected. I cant access the audio or SatNav and the amber light on the power button flashes constantly.

Any ideas on what it could be and how to fix it?
 

·
Premium Member
Joined
·
1,321 Posts
You mean.. in accessory mode? When you just get in the vehicle? When the vehicle is on?

"The Range rover logo is constantly shown when the key is detected."

yes.. it's supposed to be like that, even when the key isn't detected. When you figure out your question, report back.
 

·
Registered
2013-2015 Range Rover MkIII / L322
Joined
·
2 Posts
Discussion Starter #3
You mean.. in accessory mode? When you just get in the vehicle? When the vehicle is on?

"The Range rover logo is constantly shown when the key is detected."

yes.. it's supposed to be like that, even when the key isn't detected. When you figure out your question, report back.
Hi, sorry if my question wasnt clear. Basically I cannot access my SatNav or Audio (Radio and stuff.) Theres clearly something wrong because I turn the car on and off and I still cant access it. When I turn the car on with the key in and stuff the range rover logo doesnt disappear. Ive tried pressing every button but to no avail. It wont go away. Ive read about online with posts saying it could be my amplifier? My optical fibres? Im really not sure. I appreciate your reply :)
 
1 - 4 of 4 Posts
Top