Range Rovers Forum banner
1 - 1 of 1 Posts

· Registered
1995-2002 Range Rover P38A
Joined
·
118 Posts
I had this problem since i bought the RR a little over a year ago. First I managed it by giving it a thorough work-out, let it scan the disks several times, pulled out the cartridge, put it in again, let it scan the disks again. Worked a short while, then, as I wanted to change to another cd, it got stuck again. So had to be some ceased grease or so.

Took it out and apart, and tried to clean the metal surfaces, where sliding actions happen, used silicone electronic grease, but after a few days, the drawer got stuck again. I didn't have any problems with the worm gear.

Seemed to be the sliding arm and the black plastic-slider attached to it - and driven by the large black gearwheel on the top. With power on the unit, just give it a short push with a fingernail, and it might move so much, so it's possible to get the cartridge out, if it's stuck.

I cleaned the gliding surfaces with grease remover and (yes, i know, but I didn't thing I had anything to lose) with brake cleaner on cotton swabs, while moving the units back and forth. The sheet metal plates on the front and back for moving the drawer/reader unit up and down, there's a white medium size gear wheel at the bottom side, backwards, again with caution and a fingernail, it can be moved. As for the drawer, it's as mentioned, the large black gear wheel on top.

Cleaned as good as possible, put some oil (acid free, sowing machine oil or equivalent) on the gliding surfaces and tried it out, worked. And now, a few days later, it still works, I can still change cd! And I hope it keeps going some time.

I'm planning to change input plug on the head unit (have got one with the right plug for at Blaupunkt HU), and letting a "silent disk" run in the changer - there was a thread here somewhere, but I cant find it anymore. Any of you know, how to search or what the title was (can't search for aux, it's too short), maybe able to post a link?
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top