RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello everybody ,
i'm new on the forum so I'll introduce myself first.
I'm etienne ,38 yrs old from the netherlands and i own a range rover p38 4.6 hse from 1996 with 337000 km on it since 6 weeks now and i'm really pleased with it (read; happy as a child :D ).
I've been looking around on the forum since before i bought the car and want to applaud :clap: the people who made this site possible and all its contributors cause its really good in terms of indepht knowhow and howto's and seeing how much info was available on it really made my consideration for bying the car a lot easier. :thumb:
I just drove the car since i Bought it but I'm gonna give it a thorough servicing and fix some small problems so it will be in ship shape again.
After that ,given time and money of course, i wanna give it a look like the newer 2005 models and some new rims.

Glad to be a member of the forum and hope to make a proper contributions.

Greetings to all from dinkyboy :wink: .
 

·
LIFETIME CONTRIBUTOR
2002-2005 Range Rover MkIII / L322
Joined
·
5,427 Posts
Welcome aboard, dinkyboy. I hope we can help you.
 

·
Registered
Joined
·
206 Posts
Welcome !

Wow, that's a lot of kms. You should go over that P38 with a fine brush, there are lot's a parts that without proper and constant maintenance will crumble to dust.

N.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
Hello Mr beckett and Nachoman77,

thnx for the welcome and happy to be aboard.
I'm sure the forum can help me cause it allready did and will no doubt do so in the future :) .
And Nachoman like you said it's a bunch of clicks on my p38 but i'm the 4th owner and the first 2 had it serviced at the dealer and after that it was a fan who kept it in good shape and kept the receipts of the repairs and maintenance done so i could see what was done on the car before i bought it .
Nevertheless there are some problems now and i'm gonna look into them;
-ticking noise from the engine's right bank(probably sticky valve's,carbon deposit or a "jammed" hydraulic tappet)
-a worn suspension airbag on the rear left(and the other 3 look like their gonna need replacement soon enough)
-cruise control won't come on( I'm guessing vacuum hoses)
-the a/c warning sign came on(500 km after i bought it!)but 40k km ago it got a new a/c compressor ,condensor,and radiator so it probably just needs a refill :pray:
-the tranny ecu needs replacment cause it runs just fine in all gears but it keeps telling me to put it in N
-one of the pneumatic lifter arms for the rear upper tailgate was shot.
-the rear windowwiper doesn't spray anymore

hey otherwise it's fine :lol: .

I have to admit that all this wisdom comes from the forum and the site so you guys allready helped me :thumb:

Thanks and i'll be keeping in touch via the p38 forum.

Greets everyone from holland.
 

·
FOUNDING MEMBER
2002-2005 Range Rover MkIII / L322
Joined
·
860 Posts
A big welcome from the L322 forum.

We look forward to you joining when you move up to a newer vehicle
 
1 - 6 of 6 Posts
Top