Range Rovers Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hello,

On my '01 P38 lately every time the alarm goes off the horn does not sound. The system works since when it's tripped from the inside of the cabin you can hear the clicking of the relay on and off but the horn doesn't sound. Similarly if you leave the bonnet open and try to lock the car with the keyfob you don't hear the beep either as you normally would. There are no fault codes. Has the alarm horn quit working? Is there a relay I can check before testing the alarm horn?

Any help is greatly appreciated.

Thank you,

Calguy
 

·
Administrator
Joined
·
27,834 Posts
The alarm horn is separate from your traffic horn. It is located by your underhood fuse box, somewhat easy to get to and easy to test the wiring. Has it ever worked? If not I would suspect someone may have disconnected it if they were having alarm issues.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
Thank you for the response. It's always worked before. I suspect either the horn has failed or a relay or fuse is blown. Last time it worked fine was before my battery died. After I replaced my battery months later I noticed one day when I had the bonnet open that the horn didn't beep when I locked the truck. Don't know if a connection is to blame or the horn. I read elsewhere on here that the later model p38 have a bbus type alarm horn that has it's own internal battery... Could that have failed?
 

·
Administrator
Joined
·
27,834 Posts
I think you will find the internal battery is for back up purposes should someone disconnect the battery or cut wires while trying to break in/steal the rig.
 
1 - 4 of 4 Posts
Top