RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
Hi all,

I have a 2003 L322. For a while now the alarm has been going off when I unlock the doors. It goes off for about 25 seconds or so and then stops.

The doors unlock fine and I can start the car immediately, but the alarm keeps sounding off. This used to be an intermittent problem but now it happens every time I unlock the doors. I have tried both keys using the remote and the door lock - with the same result.

Has anyone experienced this issue and found a solution for it? Is there a way to disable the alarm sound completely?

Many thanks!
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
101 Posts
Sorry to hear about your alarm issue. I continue to have and have always had an issue at certain stores, particularly Home Depot; my understanding is that their building alarm somehow weakens my remote key locking, so I have to lock the doors manually with the key. If I unlock manually the alarm always sounds but it stops when I start the car ( knock on wood ). Sometimes when I unlock manually I turn to the unlock position twice and it prevents the alarm from sounding. Since the remote unlocking still produces your alarm and starting your car does not stop the alarm your issue sounds more extreme. Good luck!
 

·
Registered
Joined
·
75 Posts
Discussion Starter #3
Thanks for the reply. I don’t think it is an interference issue as this happens wherever I am parked. I tried locking/ unlocking with both keys and keyfobs, unfortunately to no avail.
 

·
Registered
Joined
·
1 Posts
I am having the exact same issue. Did you ever find resolution?

Hi all,

I have a 2003 L322. For a while now the alarm has been going off when I unlock the doors. It goes off for about 25 seconds or so and then stops.

The doors unlock fine and I can start the car immediately, but the alarm keeps sounding off. This used to be an intermittent problem but now it happens every time I unlock the doors. I have tried both keys using the remote and the door lock - with the same result.

Has anyone experienced this issue and found a solution for it? Is there a way to disable the alarm sound completely?

Many thanks!
 

·
Registered
2009 L322 SC
Joined
·
22 Posts
I haven't had this issue on my RR, but I had a 1998 BMW 528i that had that exact issue after I bought it. Not sure if the alarm siren on the L322 is the same or similar, but the issue with the 528 was a dying battery inside the siren module. The battery recharges when the vehicle is in operation, but my 528 sat for a long time before I bought it and the battery had worn down. It is a tamper resistant mechanism if a thief tries to cut power to the system the alarm will sound. I bought a new siren for it but the more I drove it the less frequent it happened and I never replaced it. I still have it in my garage but traded the 528 for the L322, so I don't need it. If you find it it's the same part, I'll sell it to you cheap just to get rid of it. Either way, I hope that helps.
 
1 - 5 of 5 Posts
Top