RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
1995-2002 Range Rover P38A
Joined
·
11 Posts
Discussion Starter #1
Hi All,

Firstly, Happy New Year to you all.

Secondly, Air Suspension! I had a problem early last year with the Air Suspension which turned out that the pump had stopped working. I had the flashing light on the central dash/switch area quite quickly followed by the and "EAS Fault" warning.

Today I was driving in the poring rain and, as you do, going through a few puddles (some quite deep) etc. I stopped at 'the dump' and put the suspension down. When I drove off the suspensions was 'bouncy' and the light on the dash was flashing. The light eventually went solid but the suspension still didn't feel right. I then stop off at Tesco and put the suspension down. Got back in and the light has continued to flash and the suspension feels bouncy at the rear end.

The issue SEEMS to be effecting just the the rear of the car. In going through all the water have I dislodged one of the 'ride-height' sensors?

The dash is not showing any 'EAS Fault' warnings.

Any clues greatly appreciated.

Cheers

Austin
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
4,199 Posts
Might have a dodgy rear sensor, though if the compressor is running all the time then it could be a case of the compressor seal having worn out so it's taking forever to get enough air in to lift the vehicle.

Easy test for compressor is start the vehicle with a door open and see how long it takes for the compressor to shut off from an empty EAS tank. If it's more than 6 or 7 mins or it doesn't stop at all, then it's not generating enough pressure.

If it does fill the tank in that time, then close the door and remind the EAS of the target height. If it doesn't shoot straight up then maybe the valve (s) are sticking. If it goes straight up, then may be a height sensor that's confusing it.

I'd almost go out on a limb and say it's the compressor though.

Marty
 
R

·
Guest
Joined
·
0 Posts
might help if you wrote more clearly about what lights are flashing and solid? even in the middle of the dash there are 4 of them

might be a sensor that got water in, or has a dislocated/broken arm (not advisable to drive with that)
 

·
Registered
Joined
·
75 Posts
I had similar problem after valve block and compressor rebuild. It took forever to get from highway mode to normal, light kept on flashing and I got EAS fault twice next day. The problem was compressor thermal switch. Ordered from ebay, changed it and problem solved.
 
1 - 4 of 4 Posts
Top