RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello,all,

I have a FF Range Rover 04 plate.

After stupidly updating my air suspension Ecu with my T4 (don’t ask) I now have a front cross link valve fault.The system was working perfectly before I done this, so I believe I’ve updated it with a older version of the software.

As I believe 04s don’t have a front crosslink valve.

My T4 disk is disk 19 08/2005 DJDOD19. Suspension ecu number RQT000013 HW20 SW40 week 28 03.

Can anyone help me out with any information how to solve this? I’m guessing I need a later disk.. but can I find one to purchase..!

Thanks in advance.
 

·
Administrator
Joined
·
27,821 Posts
Actually early 2004s still had the crosslink valve. It was deleted part way through 04 Model Year production and replaced with an inline connector.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Actually early 2004s still had the crosslink valve. It was deleted part way through 04 Model Year production and replaced with an inline connector.
Thanks for the reply, I’m guessing the only real way of knowing is having a look.

Mine being an 04 will definitely have it? Would the chassis number help?

i just can’t understand why it’s been fine all this time...
 

·
Administrator
Joined
·
27,821 Posts
I doubt that the dealer would even have the change over VIN. It was not a major change. Crawl under and look. If you have the valve then then you know the fault is most likely real. If you have the inline connector your fault code is erroneous.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I doubt that the dealer would even have the change over VIN. It was not a major change. Crawl under and look. If you have the valve then then you know the fault is most likely real. If you have the inline connector your fault code is erroneous.
Ill have a look, thanks.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
For those who are looking in the future, ive looked and it doesnt have the front cross ink valve as i thought.

so...still looking for that disk...
 
1 - 6 of 6 Posts
Top