RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
i just drove my 1999 range rover home and it was all working fine, then i hoped back in it and started it up and all the height selctions were flashing and so was the air suspenion light on the dash? as i drove they allstoped flashing and just all stayed on and none of the suspension selections are working? any ideas?
 

·
Registered
Joined
·
132 Posts
Hi there blind249,

Yeah, your EAS is faulty.
For a start, look at the sticky up the top of the P38 forum. There's a LOT of information there, this will get to going on a diagnosis. Often it's something that you can easily fix yourself :dance:

Cheers,
Mick.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
i tried conecting pins 1 and 8 but the compressor did nothing? does that mean that im up for a new compressor?
 

·
Premium Member
Joined
·
1,855 Posts
Check between pin 1 and an earth, for 12v. You only have 12v to pin 1 for a minute or so after ignition is off. Leaving it in ignition-II (with or without engine running) will give you power at pin 1 all time ignition key is there.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I hooked the compressor up to abattery and it worked fine so it's not that. Is there a way of clearing the eas fault?
 

·
Registered
Joined
·
517 Posts
blind249 said:
I hooked the compressor up to abattery and it worked fine so it's not that. Is there a way of clearing the eas fault?
Are you asking if there is a way to read and clear the stored fault codes?

If so there is plenty of information on the forum - all available via the search button, but as a starter the cheapest way is detailed here - http://www.rangerovers.net/repairdetail ... tware.html

a few more pages you can read - viewtopic.php?f=8&t=22223

Then there's the EAS kicker or MSV from Blackbox

or your local indy or main stealer with their T4 or Autologic
 
1 - 6 of 6 Posts
Top