RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
2006-2009 Range Rover Sport
Joined
·
123 Posts
Discussion Starter #1
I've been working for a while trying to figure out why my front suspension drops over a period of several hours. This is an '06 HSE with 58k miles and out of warranty. I did, however, bring up the issue near the end of the warranty period but the dealer wrote it off as "normal". In Normal height, after being parked, it now drops over an inch or to the bump stops. After starting it pumps right back up.

Yesterday I decided to really start looking in more detail. I have a Faultmate MSV-2 so I decided to go through a series of tests. Included after the text/data are some pictures as well as part of a system schematic I found somewhere on the web. Still trying to get signed up for the full online manuals.

1) Remove inner fender panel on right side to check the front valve block. Applied soapy water to all 3 airlines on the block plus on the bags. Could see no new bubbles. A nice trick to remove the inner fender panel is to take a set of ring pliers and turn the right angles inward to pull the clips apart. There are 6 clips and 8 screws.

2) Raised the RRS to off-road height. Monitored the 4 corners plus system pressure.
a) Started at 48/43/40/39 and pressure 614kPa (the numbers are the system heights after calibration for LF/RF/LR/RR)
b) After 1.5hr: 42/40/41/40 and press 399
c) This mostly shows a drop in pressure and the front slightly lower.

3) Set height to normal
a) Start: 0/-1/-1/2 and press 1552
b) After 1hr: -4/-6/-1/1 and press 391
c) Again, drop in pressure and front slightly lower. Now it gets interesting....

4) Opened front valves, then opened reservoir valve. Vehicle really started raising front so I quickly shut all valves.
a) Opened exhaust valve and bled off system pressure.
b) Heights 39/34//0/-1 and press 165
c) Closed exhaust.
d) After less than 10 minutes: Height 39/35/0/-1 and press 245 (pressure is climbing at this point)
e) After 45 minutes: 36/32/0/-1 and press 372
f) After another 3 hours: 15/13/-1/-1 and press 340

5) Opened and closed exhaust valve again.
a) Start: 15/13/-1/-1 and press 184
b) After 5 minutes: 15/13/-1/-1 and press 215

6) This morning:
a) No changes to system inputs after last data: -44/-49/-1/-2 and press 257 (increase in pressure over night before)

7) Opened and closed reservoir valve.
a) Start: Pressure 1283
b) After 10 minutes: Pressure 820 - no change in height.

I still need to check for air leaks around the other connections near the center block and back. The theories I'm chasing so far:
1) Front valve block.
2) Air leak between front block and center block.
The front valve block is sticking or not closing all the way - probably 2 of the 3 valves in the front block. When I bleed off system pressure(exhaust valve), I would expect the system pressure to remain steady. But it increases to a point. This could also be a faulty reservoir valve but I don't see evidence of the reservoir running out of pressure. In the mornings it quickly pumps up - if the reservoir valve were leaking and there was also an air leak to the outside, I wouldn't expect a quick pump. Then if there's an air leak between the front valve block and the center block, the pressure drops again and the front bleeds off as well since there's a problem.
If the front bags or connections have a leak, I'd expect one side to go down unless the crossover is faulty. But then the system pressure should remain the same unless there's a leak there as well.
In all of this, the rear has remained steady.

Anyone else have ideas?? I figure I'll check a few more connections but since front valve blocks are only ~$125 I'll just replace it. Looks like it can be opened and rebuilt but I want to make sure I have new Voss connectors handy.

Pics, also showing the nice "clean" fenderwell after PA road salt:








 

·
Registered
2010-2012 Range Rover Sport
Joined
·
83 Posts
Ahhh. This is why it takes a minimum of 4 days in the shop to get anything on my 2010 sport diagnosed and fixed!

Nice writeup. You probably fixed something on your own that the dealer didn't have any hope of figuring out.
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
Nice writeup geflackt. Just curious where is the pressure reading being taken that you are quoting?
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
123 Posts
Discussion Starter #4
Pressure is the reading being taken by the computer - #12 on the diagram. I don't have a separate fitting.

In the next night or 2 I'll take the cover off the center valve block/compressor section and soap up the fittings. I think I saw a bit of a bubble grow on the front valve fitting to the main supply. But I'm also still thinking there's an issue with the front block. We'll see. May have it sorted over the weekend if things go well.
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
123 Posts
Discussion Starter #5
PART OF THIS MAY BE FIXED!!!

Last night I replaced the front valve block(PN RVH000095) with a new part(<$125) in about an hour. No change in height overnight or during the day today!!! I do still get a large drop in the "gallery pressure" or the pressure in the center section. Reservoir stays pressurized, though. So there is still probably a leak either in a central line or one of the exhaust valves is sticking. I figured there were 2 problems but wanted to get the front drop solved first. So far so good.

I decided to open the old valve block. Doesn't look too bad. The original problem could have been possible dirt at the valve seats. I simply installed the new part but thinking back it would have been a good experiment to clean/lube the old block and re-install. I did re-use the original Voss connectors rather than the new ones supplied with the new valve block.

Here's the old valve block somewhat disassembled(not visible are some o-rings still in the housing). The center valve is the cross-link valve and has different construction than the corner valves.
 

·
Registered
Joined
·
6 Posts
RE: Where can I find the Air Suspension Diagnosis Diagram for my 2007 RR HSE. My rear suspension leaks down to the bump stops overnight. I want to locate all of the components and hoses to/from them. Your assistance is greatly appreciated.
 

·
Registered
2009 Range Rover Sport HSE
Joined
·
28 Posts
RE: Where can I find the Air Suspension Diagnosis Diagram for my 2007 RR HSE. My rear suspension leaks down to the bump stops overnight. I want to locate all of the components and hoses to/from them. Your assistance is greatly appreciated.
I have the full manual in PDF (178MB file). Too late for you now I'm sure, but if you (or anyone else reading this) are still interested, share a public Dropbox or Google Drive link and I can upload it.

To quickly answer your question about components in summary text form:
  • rear air valve block is secured to the housing around the rear driver side air strut (there is only one block for the front and one for the rear)
  • it should be pretty obvious where the hoses go to / come from once you locate the air valve block
  • the height sensors are near the air struts / axles
  • air compressor is in front of (i.e. towards the front of the car) the rear driver side air strut
I don't know if you MUST remove the spare tire. I did and was able to use the space to work on replacing the struts at some point during the job.

287674
 
1 - 8 of 8 Posts
Top