RangeRovers.net Forum banner

61 - 80 of 107 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter #63
Anyone get the answer to this question?
Thank you
I haven’t been able to find any cross compatibility documentation. The DPLA is the one several of us have used. You can see if you can find someone with a return policy and try the FPLA. That would be a great benefit to the community.
 

·
Registered
Joined
·
22 Posts
Anyone get the answer to this question?
Thank you
On a Land Rover parts site in the UK I searched the US sensor part number. The site said that part number was superseded, it showed the new part number and a picture showing the part. Zooming in on the picture It was either a HPLA or a FPLA the resolution wasn't great, but it wasn't a DPLA. After that I found a poorly engineered website for Delphi. I searched the part number but nothing came up. I've had zero luck finding a used DPLA on any eBay site. I must be using the wrong search terms as JetLag said he saw a bunch of them in Europe, but I came up with nothing.
 

·
Registered
L494 V8 SC Dynamic
Joined
·
211 Posts
On a Land Rover parts site in the UK I searched the US sensor part number. The site said that part number was superseded, it showed the new part number and a picture showing the part. Zooming in on the picture It was either a HPLA or a FPLA the resolution wasn't great, but it wasn't a DPLA. After that I found a poorly engineered website for Delphi. I searched the part number but nothing came up. I've had zero luck finding a used DPLA on any eBay site. I must be using the wrong search terms as JetLag said he saw a bunch of them in Europe, but I came up with nothing.
I also have not found a DPLA for sale. Plenty of HPLA/FPLA though.
 

·
Registered
Joined
·
110 Posts
On a Land Rover parts site in the UK I searched the US sensor part number. The site said that part number was superseded, it showed the new part number and a picture showing the part. Zooming in on the picture It was either a HPLA or a FPLA the resolution wasn't great, but it wasn't a DPLA. After that I found a poorly engineered website for Delphi. I searched the part number but nothing came up. I've had zero luck finding a used DPLA on any eBay site. I must be using the wrong search terms as JetLag said he saw a bunch of them in Europe, but I came up with nothing.
Just looked and you’re right, not a one right now. I actually ended up buying two by accident and then cancelled the other one. I’ve just looked it up and it sold a few weeks ago.
 

·
Registered
Joined
·
25 Posts
Decided to play Guinea Pig. I found an FPLA for $200 shipped on ebay. Just ordered it, along with everything else needed. It supposedly came off of a 16 L405, and research tells me there are several L494's that came with this number from the OEM. I assume at some point one part number was replaced with the other. Ultimately I will find out and let you all know. I'm hoping I have luck getting a hold of GAP to get my full CCF. It seems others have not gotten response from them. I ordered their tool this morning and sent them an email. Wish me luck on all fronts!
 

·
Registered
Joined
·
22 Posts
Decided to play Guinea Pig. I found an FPLA for $200 shipped on ebay. Just ordered it, along with everything else needed. It supposedly came off of a 16 L405, and research tells me there are several L494's that came with this number from the OEM. I assume at some point one part number was replaced with the other. Ultimately I will find out and let you all know. I'm hoping I have luck getting a hold of GAP to get my full CCF. It seems others have not gotten response from them. I ordered their tool this morning and sent them an email. Wish me luck on all fronts!
I just bought an HPLA guess we'll see how it goes!!!
 

·
Registered
Joined
·
118 Posts
Discussion Starter #70 (Edited)
Decided to play Guinea Pig. I found an FPLA for $200 shipped on ebay. Just ordered it, along with everything else needed. It supposedly came off of a 16 L405, and research tells me there are several L494's that came with this number from the OEM. I assume at some point one part number was replaced with the other. Ultimately I will find out and let you all know. I'm hoping I have luck getting a hold of GAP to get my full CCF. It seems others have not gotten response from them. I ordered their tool this morning and sent them an email. Wish me luck on all fronts!
Great, keep us up to date. If it comes off of a L405 it'll probably work. It'll be interesting if you will need a calibration or not for it to work. Seems like if the sensor is a used part the calibration file from the last vehicle is stored in the sensor module its self. Since the L405 and L494 share basic configuration the file should be close.

I just both an HPLA guess we'll see how it goes!!!
See if you can find out what it came out of just for others future reference. It seems all of the Jaguar / Land rover units are physically the same but on the UK boards some got scammed and the seller sent them a unit out of a Jaguar that contained the wrong firmware to interface with our systems. In the end GAP was able to provide them a new firmware flash but its best to avoid that problem if possible.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
268 Posts
Finally was able to get a hold of GAP, thanks @jetlag for that other email!

I too am going to "guinea pig" it up with this LR JAG sensor I found on eBay for too good of a price to pass up on. It's # is GX73-9G768-AD

picture attached... I guess we'll see if it works.

286020
 

·
Registered
Joined
·
118 Posts
Discussion Starter #72
Finally was able to get a hold of GAP, thanks @jetlag for that other email!

I too am going to "guinea pig" it up with this LR JAG sensor I found on eBay for too good of a price to pass up on. It's # is GX73-9G768-AD

picture attached... I guess we'll see if it works.

View attachment 286020
Awesome, I think that’s out of a Jaguar. Based on what I gleaned from forum posts the first four digits are the vehicle it was for, second set is the part it self (hardware), and the last two is the software revision it was on when new.
It looks like all the H,F,D PLA units were Rover and the others are Jag. if anyone knows different let us know.
Worst case you’ll just need to flash the firmware on it. GAP has done that before and can help you.
 

·
Registered
Joined
·
22 Posts
Great, keep us up to date. If it comes off of a L405 it'll probably work. It'll be interesting if you will need a calibration or not for it to work. Seems like if the sensor is a used part the calibration file from the last vehicle is stored in the sensor module its self. Since the L405 and L494 share basic configuration the file should be close.



See if you can find out what it came out of just for others future reference. It seems all of the Jaguar / Land rover units are physically the same but on the UK boards some got scammed and the seller sent them a unit out of a Jaguar that contained the wrong firmware to interface with our systems. In the end GAP was able to provide them a new firmware flash but its best to avoid that problem if possible.
The person I bought it from didn't know the model, but I kept on seeing the HP on UK parts sites for a 2016 RRS so I took a shot at it. Next I need to source the steering wheel control and the mount. I keep on kicking around the idea of the newer touch steering wheel controls but I'm thinking I'm in deep enough at this point!. Did the mount for the module come with bolts or do I need to track them down?
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
268 Posts
The person I bought it from didn't know the model, but I kept on seeing the HP on UK parts sites for a 2016 RRS so I took a shot at it. Next I need to source the steering wheel control and the mount. I keep on kicking around the idea of the newer touch steering wheel controls but I'm thinking I'm in deep enough at this point!. Did the mount for the module come with bolts or do I need to track them down?

Mine did NOT come with bolts.
 

·
Registered
Joined
·
118 Posts
Discussion Starter #75 (Edited)
The person I bought it from didn't know the model, but I kept on seeing the HP on UK parts sites for a 2016 RRS so I took a shot at it. Next I need to source the steering wheel control and the mount. I keep on kicking around the idea of the newer touch steering wheel controls but I'm thinking I'm in deep enough at this point!. Did the mount for the module come with bolts or do I need to track them down?
The module does not come with the bracket or bolts. The module pops into the bracket with a friction fit on 3 posts. You can find the part numbers for the bracket and bolts in my original posts on this thread.
 

·
Registered
Joined
·
1 Posts
Dear all!

Greetings from Luxembourg, Europe.

Firstly, I am new to this forum, but was so impressed with Gpplutta’s ACC retrofit documentation that I had to sign up, hoping that one of you might be able to help me with my incomplete ACC-retrofit?

I own a LR Discovery 4 (LR4/L319) 3.0, SDV6, LHD, German Model, Model Year 2016 (final model year of the D4).

As all of you, I am trying to retrofit Adaptive Cruise Control (ACC) to it, as my car came only with the standard Cruise Control.

Anecdotally, I am aware of successful ACC retrofitting cases for LR Discovery 4 (2010-2016) and even on predecessors: LR Discovery 3 (2004-2009), and also the 2016+ largely identical Range Rover Sports (RRS, L320/L494), too. So there is sufficient evidence to believe that ACC can be retrofitted to my LR4.

By now, we managed to retrofit the various missing hardware components (e.g. the forward-facing radar unit, bracket, and the upgraded ACC-distance switches on the steering wheel, see photo below).
Source for these parts was the VIN from another Discovery 4, which already came with a factory-fitted ACC (we believe the Model year was either 2016, like mine, or 2015 = close to mine)

Both, the radar unit (new) and the ACC-distance switches (new) are connect to my pre-existing ACC-wiring harness in my D4, and the respective ECU. This means from a high-level hardware perspective, all the components are present and fitted.

However, there is a problem, which we currently believe is related to some firmware/communication issue with the retrofitted ACC control-switches on the steering wheel. Somehow the ECU recognises, but struggles to communicate with the switches. I do have the GAP-IID BT Tool, as it might play a role is solving the issue?

286187


My question to you:
Could you share your thoughts on what I could try next? Does the above sound like a ‘firmware’ flush issue? If so, I am assuming that something isn’t compatible yet, but is there a firmware for the switches, I need to replace, or is it all ECU related? So is this (likely) something that GAP might be able to help with? What should I ask for?

If any of you has an idea where I could continue to untangle this, I would be so grateful!

Cheers, Raoul
 

·
Registered
Joined
·
22 Posts
SUCCESS! I can now confirm that the FPLA module works 100% on a 16 L494! Easy install, no calibration needed. Love having this feature!
Great to hear!! I've received my HPLA, just waiting on the switch pack and mount. Hopefully I'll get it done next week.
 

·
Registered
Joined
·
25 Posts
Good luck! My Super Duty has this feature and I’ve been pining for it in the Rover ever since I used it. Super stoked
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
268 Posts
Well, finally got around to installing the sensor I found on eBay and got the bumper back on. I had GAP send me the firmware for build 2702 of the tool.

I updated the device but when in configuration I dont see any CCF options to change what was shown on page one of this thread.

286425


286428



286426


286427
 
61 - 80 of 107 Posts
Top