RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2006-2009 Range Rover Sport
Joined
·
4 Posts
Discussion Starter #1
Air condition don't work. Low side pressure is too high and high side is too low. I think that the termostatic expansion valve is broken. I think that this part is difficult to reach. Does anyone know how to replace this part? Car is 1st gen Range Rover Sport 4.4 V8 petrol.

Best Regards,
Juha
FINLAND
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
4 Posts
Discussion Starter #2
Now I know the location of expansion valve. It is near to evaporator. Almost the entire dashboard must be removed. **** it:evil:
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
4 Posts
Discussion Starter #4

Thank you, Rover has become familarm both good and bad. Fortunately, I can fix it myself. Yes I know if compressor run it doesn't mean it's working, but I think that it's working. Sometimes it gives a little cold. Lowside pressure is 85 psi, when engine don't runing. When I start the engine and compressor runing lowside pressure decreaases slightly to 75 psi, at same time the high side goes little up, but not enough. I can't remember exactly high side pressure, but it is not much higher than the low side pressure. I have to check compressor before I'll start changing the expancion valve. I still have to think about how i could easyli check it out.
 

·
Registered
Joined
·
53 Posts
Only way to know for sure is to pinch off a refrigerant hose or replace the compressor. The hoses are really stiff so you won't be able use pinch off pliers on them.
 

·
Registered
2013-2015 Range Rover Sport
Joined
·
159 Posts
Compressors are really common on these. I have replaced one a week for the last few weeks here in the shop. Doubt the expansion valve has an issue, Have not seen one fail yet on one of these.
 
1 - 6 of 6 Posts
Top