RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
1970-1995 Range Rover Classic
Joined
·
29 Posts
Discussion Starter #1
I just walked in the door from a drive back from the beach. The AC was blowing cold and the CD changer was playing on the way home. All of a sudden the AC and the CD player cut off at the same time, completely losing power. No air will blow at all..hot or cold. The radio will still cut on but the weather band and the radio will not play any sound. I just sat down to relax for a few before doing some trouble shooting. Any thoughts?
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
29 Posts
Discussion Starter #2
A couple updates: My flashers, drivers seat, and radio/cd player do not function either(although my radio has never picked up a station). I have the panels removed below the steering column and passenger side kicker panel to gain access to the correct relay that is causing these issues.

Has any one had this problem before?

I found this post about the same issue but I can't get a response...
viewtopic.php?f=4&t=40205
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
29 Posts
Discussion Starter #3
Ok..I have my problem fixed now. Thought I would post the fix up here in case any of you run into the same problem as I did... It turned out to be my fuse link wires. After finding the problem, I discovered more problems. Here is how I solved them with detailed pictures...

http://www.lrrforums.com/showthread.php?t=17129

Hope this helps...
 

·
Registered
Joined
·
300 Posts
Just read your posts on the lrrforums; glad you've got your problems sorted :thumb: reading through it reminded me of when I owned my LSE and all the little irritating electrical problems-which I eventually managed to sort out :lol:

Sorry you didn't get any replies on here though :oops:
 
1 - 4 of 4 Posts
Top