RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
I am trying to work out a gremlin in my horn. I bought his car a couple of weeks ago and the horn has never worked. I checked Fuse #10 and it's fine (I replaced it just in case). I know that there is a horn relay, and in photos posted here by another member the relays are directly above the fuse box in the glove box on a 2005. I have not pulled my glovebox completely apart (yet) but it does not look as if there could be relays in this position due to the newer glove box. Does anyone know where the relays are in a 2006 RR SC?

Also, does this model year suffer from the dreaded FSR issue? I have had a dead battery a couple of times, and I think that the actual battery itself is losing it's punch. But before I replae the battery I am curious if there might be another cause.

And last but not least when playing videos on the DVD I get a blank screen up front. Even while parked with the key in position 1. I can hear the video playing, I can see the Logic 7 logo and the "Mini" screen in the upper left hand corner of the display, but it's all black...no picture. I can then "touch the picture" to enable the full screen view, but still all black. Am I missing somthing here? Is it user error?

Any chance all of my issues are related?

An help here would be greatly appreciated!
 
G

·
Guest
Joined
·
0 Posts
Try the fuse again. Another user on here had a similar issu and said the same "checked fuse, all is good". Turned out it was not fully home. Check the obvious again, just to be sure.

As for the FSR, I think it only affected up to MY05. Your 06 should be ok. You should be able to take your battery and get it tested FOC. i urge you to do so.
Now.

Right now.

What are you still reading this for :doh: go get your battery tested.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
cmarshack said:
And last but not least when playing videos on the DVD I get a blank screen up front. Even while parked with the key in position 1. I can hear the video playing, I can see the Logic 7 logo and the "Mini" screen in the upper left hand corner of the display, but it's all black...no picture. I can then "touch the picture" to enable the full screen view, but still all black. Am I missing somthing here? Is it user error?
If you are in the US (speaking of which, why not adding your location as part of your forum profile?), that's working "as intended". Some retard at LRNA's legal department decided that it was too dangerous for North American front passenger and driver to enjoy a DVD on the touchscreen monitor, even with the car in Park. :doh: It took them 2 years to come to their senses (I think MY08s and later allow video playback on the touchscreen - only while stationary, which makes perfect sense), but if you have a MY06 or 07 in North America your only option is to install a hardware/software hack such as NavTV's - search the forum - to be able to get your front touchscreen to display any type of image from the RSES in the back. Until then, you will literally be in the dark.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #4
Mr. Range Rover- Thanks for the suggestion, the main reason that I replaed the perfeclty good fuse was because of the other post on here anout it not being "seated" properly. I thought that might be th case for me, so I removed then and replaced the fuse. The fit is very snug, so I do not think that a loose fuse it the problem.

umbertob- Wow, that is absurd! So with a 2 year old and a 4 year old, whom even though I think are very advanced cannot play a dvd on there own, I have to try to rubber neck around the seat to get past the menu screen on "Finding Nemo" even while stopped and in park? That is a huge dissapointment and I am surprised that there are not multiple topics on this. Well I guess the good news is that my car is "normal".

Thank you both for your imput and I look forward to learning more here and hopfully participating in the future.

ps. I will update my profile 8)
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
cmarshack said:
umbertob- Wow, that is absurd! So with a 2 year old and a 4 year old, whom even though I think are very advanced cannot play a dvd on there own, I have to try to rubber neck around the seat to get past the menu screen on "Finding Nemo" even while stopped and in park? That is a huge dissapointment and I am surprised that there are not multiple topics on this.
Tell me about it. That's why I purchased the Nav-TV module for my own 2006 RRS with rear seat entertainment as soon as I took delivery of the car in late 2005, money well spent if you have little ones getting restless back there. My system has paid for itself several times over, just for the peace and quiet it provided during long family trips. It's either that, or memorizing every menu screen of every kid movie in the changer until you are able navigate to the "Play Movie" button while blindfolded. :lol: As a bonus, with the Nav-TV hack you can keep watching DVDs on the front monitor with the car in motion, which is very unsafe for the driver to do of course, but not for your front passenger.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #6
I still have not worked out my horn issue.

Does anyone know where the horn relay is in the 2006 Rovers? It 's not the fuse, so I am pretty sure it has to be the relay.

If not, where is the horn located? Maybe is simply became unplugged??

Thanks again for you help on thins one.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #7
OK, so I figured this one out too!

For those who have horn trouble in the future, there is another Fuse Box and Relay Panel in the engine compartment of the 2006 (can't speak for any other molel years). There are 10 5mm Hex screws that hold the top on and then inside are the Fuses and relays.

See Pictures below:[attachment=1:2a0fw1gg]ElecBox.jpg[/attachment:2a0fw1gg]
 

Attachments

1 - 7 of 7 Posts
Top