RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter #1
Hello--I had a new A/C compressor and dryer installed in my '89 Classic last summer and it has worked fine up until recently. For some reason, the compressor won't kick on. I presume that it is an electrical connection of some sort. I pulled the fuse, but it is intact. Anyone have any thoughts about this? Thanks in advance.
Tom Lovinggood
 

·
Registered
Joined
·
87 Posts
I just went through this on my 92 RRC. It sounds like the compressor clutch is not engaging. You can check this by turning on the ac with the engine running and looking at the front of the compressor. The compressor should kick on and the whole pulley and clutch assembly should be spinning. The pulley will be spinning constantly assuming you have not lost your belt.

If the clutch does not engage, I would check the relay in the passenger footwell for the compressor clutch - on the 92 it is in the row with the orange diode pack, first yellow relay front to back. It could also be that you’ve got a leak in the system and it has become discharged. The compressor needs some amount of pressure to kick on.

Keep at it. You will find the source of the problem.
 

·
Registered
Joined
·
235 Posts
The most common reason for the AC not to kick in is the loss of refrigerant gas. Running the compressor without gas will damage it since the gas carries the lubricant and without gas the pump will soon run out of oil. For this reason there is a pressure switch in the system that cuts the power to the AC compressor clutch. You can override the switch temporarily to check if there is an issue with the electrics (rather than a loss of gas).

Ideally you find the leak, although it could be so slow you can't spot it and a simple regas will give you a few years of use. A leak is normally visible by an oil stain (since the gas carries the lubrication oil). If the compressor leaks you will see a tell tale streak of oil around the clutch when the gas leaks from the shaft seal. At times the front radiator thing (condenser) fails dt corrosion or stone damage. Both the compressor and condenser are a relatively easy to change. The evaporator inside your car would be hard part to change. If you open the system you need to also change the dryer/accumulator again, a black tube with cleans the gas and is cheap and easy to replace.

To replace the gas you need to check what sort of gas is used (R12 or R134a). Easiest to find would be R134a. You can buy cans for about $5 at Walmart and you will need 2. Ideally you use a proper gauge kit to fill, but you can use a can with adapter at least so you find out what the problem is. If you open the system you will need to draw all the air out with a special vacuum pump to remove any trace of moisture. Any trace of moisture will cause internal corrosion which really buggers the system up over time. If it is R12 (1989 I am not sure what was legal in the US) you either need to find an old can of R12, or fit a replacement gas, or change the system, to R134a. There are some legalities surrounding R12, but not so much if you do it yourself and as long as you don't vent gas you should be good. Changing to R134a is more complicated as you need to change the old mineral oil with PAG oil as the mineral oil and R134a don't work together. You could use an esther oil, but results are not guarenteed. Changing a system to R134a will reduce the cooling capacity but makes it much more serviceable.

You can read all of this on-line and buy a cheap tool set at Harbourfreight or you drop it off and get it all done for a few hundred bucks. With older cars though you might find yourself going back a few times if the shop is poor at diagnosing (nowadays they are) or paying for parts that don't need replacing.

Good luck.
 

·
Registered
Joined
·
129 Posts
First off, does the clutch plate magnetise when the temp is set to Lo and the car is running? If you whack it with a spanner does it engage?
 

·
Registered
Joined
·
5 Posts
Same issue on my '94, but not a replacement compressor (car was off the road for more than 10 years). Will check this on mine this weekend!

We tried with some refrigerant...but no dice. https://youtu.be/x_b6CnQPwmI is my video on it, and all the Rovers we rescued.
 
1 - 5 of 5 Posts
About this Discussion
4 Replies
5 Participants
dougscars
RangeRovers.net Forum
We’re a community forum to discuss and assist on issues with every Range Rover model. Sign up if you have a question, answer or to meet like minded individuals
Full Forum Listing
Top