Range Rovers Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter · #1 ·
Attempting to troubleshoot my right front door before tearing into it. I'll explain my symptoms below.

- Window does not roll up/down
- Message center says door is open when it isn't
- door lock won't actuate

Seems like the door is dead. I've read a lot about faulty latch assemblies, can this be the issue? Is there a test procedure?

Thanks for the info.
 

·
Administrator
Joined
·
27,834 Posts
Test procedures are in a big fat stickie right at the top. That'll take care of the lock and door open message. Window could be your switch pack. Door outstations rarely fail.
 

·
LEGACY VENDOR
1995-2002 Range Rover P38A
Joined
·
4,225 Posts
If nothing in the door works, then also check the connectors inside the bodywork (on the vehicle side) where the door wiring (in the rubber sheath) goes in.

There are 2 or 3 connectors there (depending on model year/spec I think) that can get water in and corrode. If the power/serial communication lines fail then the outstation will either not be powered or have communication with the BECM, and then you lose pretty much all function in the door.

As RRTH says, outstations rarely fail.... Door latch could be a possibility, but if window/mirror don't work aswell then I would make sure to check those connectors.
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #4 ·
Thanks for the info.

I saw the sticky at the top of the page immediately after posting. Sorry.

I'll take a look at those connectors. I find it strange that nothing in the door works. I thought about the window switch pack but find it odd that all other windows, sun roof and mirrors work without issue.

I'll report my findings.
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #5 ·
Finally had a chance to dig into the door. Here is what I found:

- Two connectors in the A-pillar look clean and are free of any corrosion.
- Power is getting to the outstation through the Purple/Blue and Purple/Black wires in the white A-pillar connector, confirmed power at the large outstation connector on the same wires.
- Swapped outstation from driver door and no change. Installed outstation from faulty door into driver door and it works, outstation is not the issue.

With power getting to the outstation but no activity at the door I can conclude the door is not receiving commands from the BECM. Is there a way to confirm this?
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
1,425 Posts
With a Nano, you can test things from a different angle.......
I have one here, and am currently in Newport. If you are nearby, Give me a PM.....
Otherwise, try the connectors where the outstation connects to Becm?
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #7 ·
With a Nano, you can test things from a different angle.......
I have one here, and am currently in Newport. If you are nearby, Give me a PM.....
Otherwise, try the connectors where the outstation connects to Becm?
PM sent.

Thanks
 
1 - 7 of 7 Posts
Top