RangeRovers.net Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
127 Posts
Discussion Starter #1
I have read through several radio related threads but haven't found a situation I am experiencing.

The radio lights up but there is nothing on the screen. The radio can be powered up and down without problem but nothing shows on the screen and nothing comes out of the speakers. My truck is fitted with factory Navigation which works but I don't have a map disc.

Any ideas on what to do to try and get it working?

Thanks for the info.
 

·
SUPER MODERATOR
Joined
·
27,727 Posts
Countless threads with pics to identify. 99 is a split year. GEMS had Clarion, Bosch had Alpine. No idea if Callaway carried GEMS/Alpine through the entire year.
 

·
Registered
1995-2002 Range Rover P38A
Joined
·
36 Posts
The LCD should light up with a green backlight. Similar to the color that backlights the buttons on the unit when you turn it on. If you have LCD backlighting; try to Push and hold the SELECT & BND buttons together to get you the "code in"----.

But it sounds like the LCD is not backlit and black or just not working all together.

 

·
Registered
Joined
·
127 Posts
Discussion Starter #7
The LCD should light up with a green backlight. Similar to the color that backlights the buttons on the unit when you turn it on. If you have LCD backlighting; try to Push and hold the SELECT & BND buttons together to get you the "code in"----.

But it sounds like the LCD is not backlit and black or just not working all together.

Ok, I'll try that. The backlight is working but nothing is showing on the screen.
 
1 - 9 of 9 Posts
Top