RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
This is my first RRC, but I've had a couple D1s previously, so I'm no stranger to wrenching and problem solving, But this one has me stymied.
So, the AC hasn't worked since I purchased Seamus least year. I've been digging into the issue, but haven't been able to find anything regarding my particular situation.
A previous owner has seen fit to go messing around with the wiring, now I am the one sorting it out.

There is some missing wires for the AC unit, 1) the thermostat at the temp selector switch has a couple wires that aren't plugged in and there are no obvious wires in that area to plug them in to. 2) the evaporator temp switch is also not plugged in to anything 3) there is a small black box with "Eaton" molded into it right next to the evaporator box that has 4 pair of wires coming out of/into it, and 2 of the pair are plugged in to each other. One of those is a plug that will mate up with the plug from the evaporator temp switch. I'm guessing that is where it was originally going. However , that now leaves me with a plug coming out of the black box with no where to plug it into.
My thought is that somehow it is supposed to be wired to the leads from the temp selector.

I'm assuming it was re-wired in it's current configuration due to a failure of one of these components.
Any help or pics would be greatly appreciated.

I've looked through a '92 for reference, but the AC is set up differently. No thermostat at temp selector and no black box.
 

·
Registered
Joined
·
7 Posts
The wires from temp selector green and yellow? they connect to a sliding rheostat behind controls, dont break that plastic slide. if you do it will always be set at what ever temp it was broken at either left or right-cold or warm..they go all the way to the passenger side near foot kick panel, across the evaporator and plug in to plug with same color wires. it is best to look at a wrecking yard at those wires from the black box. you wont find it in manual anywhere, at least i didnt.
 

·
Registered
Joined
·
7 Posts
The yellow and green wire from temp selector goes to the black box (2 wires on end of box towards bumper) on right evaporator bracket ,it plugs in there.
 
1 - 6 of 6 Posts
Top