RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
1970-1995 Range Rover Classic
Joined
·
28 Posts
Discussion Starter #1
When we first took delivery, I drove this vehicle about 25 miles to home with no issues. When we started it about two hours later the alt belt made a horrid squeal as it was now loose. After about a block it got quiet however within a few miles the belt broke.

I replaced the belt with an aftermarket brand from O’Reilleys.

All was well for about another 25 miles and now she is loose and squealing.

The belt appears to be well matched to the pulleys. Is this a truck that will require a Land Rover brand belt?
 

·
Registered
1970-1995 Range Rover Classic
Joined
·
83 Posts
Hi there,

Brand shouldn't really make a difference, although I buy most of my parts through Atlantic British.
My alternator belt squeals every now and again, haven't had it break though. There is an adjustment bar going from the alternator to the top of the water pump; it's a real pain in the ass to adjust everything and tighten up this bar, but if it's not done right it'll work itself loose again.
If you haven't downloaded the RAVE manual yet, go to the link below; go to page 803, and you should find instructions on adjusting and refitting the alternator belt.

Good luck!


http://www.landroverresource.com/docs/rangerover/Range_Rover_Manual_1992.pdf
 

·
Registered
Joined
·
521 Posts
Its possible that the belt dimensions are incorrect spec.

They should be flank drive, driven on the sides of the V to given a pinching effect as you run correct tension.

They should not touch the base of the belt on the bottom of the V pulley else they'll squeal at the least provocation, and not transmit enough torque to drive the alternator. This will quickly overheat the belt.

Check to see if the pulleys are getting hot quickly in use to give you a gauge as to what's happening.

For a new belt, if you straighten a section and push it into engagement with the pulley, then shine a torch through the V, you should see a gap under the root of the belt.
 

·
Registered
Joined
·
1,079 Posts
On my 91 once I reinstalled the belt
And it shredded
I had installed to tight with the adjustment
 
1 - 4 of 4 Posts
Top