RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Discussion Starter #1
Hi Canadian owners. Has anyone actually gotten the mobile hotspot to work on their cars?

I’ve brought it 2 times to the dealer. They said it was an issue with the sim, but I’ve tried my personal bell sim and the ATT sim and both do not work.

I’ve also tried enabling roaming and it still not working.
The dealer is also saying none of the ATT SIM cards work in Canada? Any truth to this?

Has anyone actually gotten to work?
Hope someone can help!


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
75 Posts
I have a 2017 and am relegated to 3G for the in-car service, so I don't bother using the hotspot, but the ATT sim that came with the car works just fine for data to the car (live traffic, etc.) once it was activated through the ATT website. That said, there are times when the entire communications module (sim, USB ports) just do not load when I start the vehicle and I am never sure when they may become active again -- sometimes on the next start, sometimes the following day, sometimes not until a week later. Obviously the dealer cannot replicate, so as far as they are concerned, that issue doesn't exist!
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Discussion Starter #4
Has anyone actually gotten the cellular to work on their 2018 in Canada?
I imagine most people don’t even care and won’t use the service?


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Discussion Starter #5
Just a quick update.
I finally got this working with the help of the dealer!


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
297 Posts
Discussion Starter #6
Also just another quick update, just noticed this morning that we just got 4G service here in Canada!



Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top