RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello! New to the Range Rover world and loving the 2020 Evoque First Edition :) Does anyone have insight into how I can TURN OFF the compass type view [think it's the Off-road information, including slope, wheel angle and compass] on the Heads Up Display? I must have selected a button the steering wheel without realizing and now this extra information is visible and extremely distracting! I've run through every option I can think of on the instrument panel to turn it off, but no luck. Any help would be appreciated if you've come across this before!
 

·
Registered
Joined
·
744 Posts
If you go into the settings for the HUD, you can turn it off. It's not a specific button on the steering wheel. You have to hit "menu" and scroll to horizontally with the arrows to goto "HUD" and you should be able to add/remove info to appear on HUD.
 

·
Registered
Joined
·
2 Posts
Have that same problem. Tried everything including going to settings. I can’t turn the darn thing off.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Have that same problem. Tried everything including going to settings. I can’t turn the darn thing off.
Such a pain right! Seems it'll flip back and forth between compass HUD view & the standard HUD view (showing only speed & a street image). The dealer was no help either - "We've never seen this before! Bring it back next week." That was back in February or March however.

If you do happen to find a solution, please do share!
 

·
Registered
Joined
·
2 Posts
So, just got back from the dealer. They fixed it in like a minute 😒. Go to your Display and turn off “off-road”. Then go to every single display layout and turn off “off-road” boxes, that includes all “left” and “right” panels, for every single layout there is. Just turn every single thing that says “off-road” off. 🤷🏻‍♂️
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
So, just got back from the dealer. They fixed it in like a minute 😒. Go to your Display and turn off “off-road”. Then go to every single display layout and turn off “off-road” boxes, that includes all “left” and “right” panels, for every single layout there is. Just turn every single thing that says “off-road” off. 🤷🏻‍♂️
So, just got back from the dealer. They fixed it in like a minute 😒. Go to your Display and turn off “off-road”. Then go to every single display layout and turn off “off-road” boxes, that includes all “left” and “right” panels, for every single layout there is. Just turn every single thing that says “off-road” off. 🤷🏻‍♂️
Wow, interesting!! Glad it was a quick fix for you! Thanks for sharing - will take a closer look and cross my fingers!
 
1 - 6 of 6 Posts
Top