Range Rovers Forum banner
1 - 2 of 2 Posts

· RIP Our Friend
Joined
·
27,964 Posts
I think you need to give them a chance to develop the fix. Would you rather they have held you car at port until a fix is developed? Personally I would rather have the car to enjoy. Such a minor glitch does not change the comfort, fun or safety of the Velar. LR is usually pretty fast on small stuff like this.
 

· RIP Our Friend
Joined
·
27,964 Posts
You are making alot of assumptions above. First off 2018 most likely did not have the same software as a 2019. You can not compare a 2018 based on same bumpers and sensors. Perhaps the sensors are from a different supplier, firmware or software can be different. Perhaps communications are different due another option you have installed.

Not all 2019 Velars have your issue nor is it a safety issue or a recall would be issued. Blanket statements and thinking LR purposely knew about this issue with your particular example is just frustration and not based in fact. How is LR suppose know about an issue on your rig if it had not been reported yet? Perhaps your description of the issue lead them to believe it was a known issue that there is a fix for. If more folks experience your issue then maybe it will give them a broader base to find the common thread causing the issue.

It makes no difference if they have sold other Velars this month. Some rigs have issues some do not. There are many owners that never have a problem with their rigs and some folks that have several issues. Is it frustrating when you have an issue and others do not? Of course it is. It is physically impossible for LR to pop out an update or fix overnight. Try to understand that something obscure may take time to figure out. Maybe do some footwork and check other Velar forum and see if you can find anyone else with a 19 in your situation.
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top