RangeRovers.net Forum banner

61 - 80 of 86 Posts

·
Registered
Joined
·
274 Posts
Would this apply to the V8's also - like a SVR?

When asking for this update from the dealer, do we reference PCM Calibration Pathfinder Release 102? Sometimes dealers play dumb, so I think it's best to come armed with the specifics.
To my knowledge there was no issue of a problem with the SVR, are you saying you have a delay at low speed?

The Release issued yesterday was for the v6 I thought they would have included both I should have inqiured more about the v8, I have the v6 so I was really focused on this one but assumed they would be fixing both. but that was when I thought the change needed to be done only on the transmission not the PCM.

The Pathfinder version that your dealer would reference will be the latest one in their system Version 232.

The TSB issued yesterday say's v6 but it all depends on what calibrations where changed in the PCM. I am not sure if it just changes the Torque curve. Ask your dealer to look into it for you.

I will see what i can find out on my end. I pull up the version number from my vehicle later tonight.

I posted the tsb on the other thread but here it is: https://www.rangerovers.net/forum/attachments/range-rover-mark-iv-l405/272718d1557514064-2018-v8-hesitation-acceleration-ltb01298nas1-delayed-throttle-response-when-accelerating-low-vehicle-speed-_-topix.pdf
 

·
Registered
Joined
·
70 Posts
Ok - thanks.

I think the SVR is a little jumpy compared to other high horsepower cars I've had (Audi, Porsche). Noticeable enough that when I stumbled on this thread, I took note.

Granted this truck weighs considerably more than other cars I own so I get it has lot to manage, but I find at low speeds and from rolling stops that it doesn't always feel like I expect it should. Comfort mode is more pronounced, but I expect that. It still exists in Dynamic.

Granted my current comparison is a late model Porsche with PDK which is flawless at any speed.
 

·
Registered
Joined
·
274 Posts
Ok - thanks.

I think the SVR is a little jumpy compared to other high horsepower cars I've had (Audi, Porsche). Noticeable enough that when I stumbled on this thread, I took note.

Granted this truck weighs considerably more than other cars I own so I get it has lot to manage, but I find at low speeds and from rolling stops that it doesn't always feel like I expect it should. Comfort mode is more pronounced, but I expect that. It still exists in Dynamic.

Granted my current comparison is a late model Porsche with PDK which is flawless at any speed.
A few ?'s

From a complete stop with a light to moderate throttle pressure do you notice a slight time gap from when you press it down until you feel the vehicle go? Or put this way, compared to your other cars does it feel like you have to push further before she moves?

Next: When slowing down from a moderate speed (more quickly than a slow gradual coast} and come to a brief stop or crawl of less than 3mph or so and than go to accelerate with slight to moderate Throttle pressure, do you notice the time lag to be greater than before?

If either of these are true than there is a modification to the torque curve, how much is hard to tell. Since my change I can tell you the Sport feels normal now. As any vehicle should. I press the peddle and I get a response whether hard or slow I get the response that is expected.

I was expecting the fix to just get rid of the initial delay but it did so much more.

Before: With the exception of out right flooring it from a stop any medium to high acceleration seemed to be gradually increased almost like a feeling of the torque converter taking to long to lock up or slipping clutches.

After: No lag time between throttle request to engine response. Feels like full power being applied almost immediately upon request. Throttle request = Engine response.

I came to realize that the the feeling of slipping clutches was the programmed slow output of the engines torque. It was gradually being increased. It all makes sense after feeling the difference.
 

·
Registered
Joined
·
6 Posts
Ok - thanks.

I think the SVR is a little jumpy compared to other high horsepower cars I've had (Audi, Porsche). Noticeable enough that when I stumbled on this thread, I took note.

Granted this truck weighs considerably more than other cars I own so I get it has lot to manage, but I find at low speeds and from rolling stops that it doesn't always feel like I expect it should. Comfort mode is more pronounced, but I expect that. It still exists in Dynamic.

Granted my current comparison is a late model Porsche with PDK which is flawless at any speed.
A few ?'s

From a complete stop with a light to moderate throttle pressure do you notice a slight time gap from when you press it down until you feel the vehicle go? Or put this way, compared to your other cars does it feel like you have to push further before she moves?

Next: When slowing down from a moderate speed (more quickly than a slow gradual coast} and come to a brief stop or crawl of less than 3mph or so and than go to accelerate with slight to moderate Throttle pressure, do you notice the time lag to be greater than before?

If either of these are true than there is a modification to the torque curve, how much is hard to tell. Since my change I can tell you the Sport feels normal now. As any vehicle should. I press the peddle and I get a response whether hard or slow I get the response that is expected.

I was expecting the fix to just get rid of the initial delay but it did so much more.

Before: With the exception of out right flooring it from a stop any medium to high acceleration seemed to be gradually increased almost like a feeling of the torque converter taking to long to lock up or slipping clutches.

After: No lag time between throttle request to engine response. Feels like full power being applied almost immediately upon request. Throttle request = Engine response.

I came to realize that the the feeling of slipping clutches was the programmed slow output of the engines torque. It was gradually being increased. It all makes sense after feeling the difference.
I have a 2018 V6 and recently purchased a 2019 V8 SC. I definitely notice the delay in the V6 and have started to notice the delay in the V8 as well. I'm glad they fixed it for the V6! I hope the V8 models get some love soon.
 

·
Registered
Joined
·
70 Posts
bill2019 - yes, there is a delay between pressing the throttle and when the acceleration kicks in. It is very subtle, but I notice it compared to when driving the Porsche (which I tend to alternate frequently these days as the weather flips around in Chicago). At first when I was in Comfort, I assumed the experience was to smooth out the ride - which 98% is fine, but it's a little too much so at very low speeds - to the point where if I need to really mash the peddle down to get out of the way (make a left turn, jump in the next lane in stop/go traffic), there is ever so slight delay and then a surge. Same thing from a rolling stop. I've come to anticipate it and I have to drive more conservatively to compensate.

Downshifting (when breaking) seems to go through the gears correctly up until you get into maybe 3rd or 2nd gear and then when you re-engage the accelerator, it seems to struggle to find the absolute right gear and you can get a jumpy or jerky motion once you accelerate again. I realize I can't push a massive truck around a corner like a sports car - but even when I had an Audi RS7 or in a Merc E63S wagon (both weigh a decent amount, but are not as top heavy), the gear progression and experience between higher speeds and lower speeds is tighter.

I need to get the new Incontrol update, so I'll bring it up with my service tech.

So it does sound very similar to what the V6's are experiencing.
 

·
Registered
Joined
·
69 Posts
I had previously commented in this thread and complained that seemed more like an industry wide issue. Seems the transmissions gets confused in what gear to be in and that causes the delay. That feeling was always followed with sudden engagement of the transmission. Felt like a brake stand.

Now that i have been drive the RRS for a week, I do feel the delay and its like nothing i have experienced before. This is literally a throttle delay. You apply throttle pressure and hold it and you can feel the vehicle slowly ramp up power. Its like driving in snow mode only with a heck of a lot more delay.

I really hope they have a solution for the V8 models, as its really annoying.
 

·
Registered
Joined
·
274 Posts
bill2019 - yes, there is a delay between pressing the throttle and when the acceleration kicks in. It is very subtle, but I notice it compared to when driving the Porsche (which I tend to alternate frequently these days as the weather flips around in Chicago). At first when I was in Comfort, I assumed the experience was to smooth out the ride - which 98% is fine, but it's a little too much so at very low speeds - to the point where if I need to really mash the peddle down to get out of the way (make a left turn, jump in the next lane in stop/go traffic), there is ever so slight delay and then a surge. Same thing from a rolling stop. I've come to anticipate it and I have to drive more conservatively to compensate.

Downshifting (when breaking) seems to go through the gears correctly up until you get into maybe 3rd or 2nd gear and then when you re-engage the accelerator, it seems to struggle to find the absolute right gear and you can get a jumpy or jerky motion once you accelerate again. I realize I can't push a massive truck around a corner like a sports car - but even when I had an Audi RS7 or in a Merc E63S wagon (both weigh a decent amount, but are not as top heavy), the gear progression and experience between higher speeds and lower speeds is tighter.

I need to get the new Incontrol update, so I'll bring it up with my service tech.

So it does sound very similar to what the V6's are experiencing.
Yes it does seem that your vehicle does have the torque delay. They put that delay in to save the transmission bushings...This delay is changing the whole characteristics of the vehicle. Once this is changed back to where it kicks in right away you will think you are driving a different rig, The you wont even realize you are driving a heavier rig.

You mention switching back and forth between cars, I have been doing this between my F pace S with the same v6 and whenever I stepped on the gas it took off like a rocket, not one bit of lag from a stop or any other time. So much more fun than driving the RRS, also made the delay of the sport stand out so much more.

Now that it is fixed I can say the engines seems equal.

Push the issue with your dealer...
 

·
Registered
Joined
·
39 Posts
Yes it does seem that your vehicle does have the torque delay. They put that delay in to save the transmission bushings...This delay is changing the whole characteristics of the vehicle. Once this is changed back to where it kicks in right away you will think you are driving a different rig, The you wont even realize you are driving a heavier rig.
I have to reiterate what bill2019 said... I was able to get this update done to my 2019 RRS V6SC yesterday, and it is truly a different car. Actually drives like a car should drive, it gets up, it goes. No wet sponge, no "oh cr*ap, I'm gonna get rear end" just normal. Schedule it, you won't regret it.
And as a bonus, I got the software update to 19A at same time, so now I can watch for future OTA updates! #bonus
 

·
Registered
Joined
·
39 Posts
Rumor is 19c is the current release.
I live in a small town... we JUST got a JLR dealership here, late last year. I was just happy they acknowledged a software update even existed. At least with 19, I should be able to handle future updates via OTA, and not have to worry about the dealership much anymore. I’m good...
 

·
Registered
Joined
·
156 Posts

·
Registered
Joined
·
274 Posts
Dont know how this thread turned into a Update thread......

I would really like to hear if anyone else had the fix done or if they plan on going in... I was loving the new feel of my rig up until Tuesday when I had to bring it in for several little things. Its been there since then and not sure when i'm getting it back. Probably going to have to go the weekend without it. Just as nice weather kicked in and I want to take it to the beach fishing.....ughhh.

Also has anyone inquired about the v8?
 

·
Registered
Joined
·
69 Posts
I believe you are incorrect. 19A is the update that enables OTA updates. 19A2 is the first OTA update. All the info is in this thread: https://www.rangerovers.net/forum/24-range-rover-mark-iv-l405/334544-ictp-ota-updates-announced-v19a2.html

That said, it doesn't appear many people have received 19A2 over the air yet.
I am doing something dangerous and referencing jaguar people, since the systems are supposedly the same thing and the updates have come out in sync. 19A enabled OTA for a while and some people got an update OTA. Many did not. It was supposedly disabled on the server side because of problems. Those problems are potentially taken care of in 19C. Again this is not direct from a dealer, and from the f-pace guys.

https://www.fpaceforum.com/forum/713921-post8.html
 

·
Registered
Joined
·
69 Posts
Dont know how this thread turned into a Update thread......

I would really like to hear if anyone else had the fix done or if they plan on going in... I was loving the new feel of my rig up until Tuesday when I had to bring it in for several little things. Its been there since then and not sure when i'm getting it back. Probably going to have to go the weekend without it. Just as nice weather kicked in and I want to take it to the beach fishing.....ughhh.

Also has anyone inquired about the v8?
Ha! sorry about that.

Since you had a lot of information that makes most dealers just look at people funny, has anyone mentioned to you about the V8s? I am hesitant to talk to the dealer just yet as i am still breaking in the motor and have not pushed it, and am not ready to start the process of explaining it to them. They know what is in topix, if it its not in that system, they are useless and i can just see the guys face when i try to reference a v6 doc. To be honest, the slow ramp up of torque is nice on a motor that is just starting its life. Once i have 500 or 1k miles on it ill ask and get the latest ICTP update while its there.
 

·
Registered
Joined
·
274 Posts
Sure I dont blame you I really didnt even want to bring mine in this early. after 4 months I only had 500 miles on it because I was so uncomfortable with the delay. all I wanted to do is drive it figures now that it is fixed The truck is gonna be in the shop for a week. Im still loving the new car smell, My f pace just as new and I made the mistake of bringing it in and after they scratched it and began repainting it when all i asked them to do was buff it out(I could and should have done it myself). and now all I smell is paint fumes for the last 2 months.

I personally never drove the v8 to see how much of a difference there was in the delay but if you do notice it bring it to their attention and show that you really dont want to live with it. They know what adjustments they made over the years and i am sure it was done to the v8. The curious thing about it the fix removed that slight peddle delay from dead stop. the same that people were buying a throttle enhancement device for like peddle commander. so I think all of them now have that delay including the v8's and if they do than there was a adjustment made throughout the years.

I will be looking in to it for anyone who has a v8 might be a little trickier since I own the v6, but i will do my best.

By the way how's your rig? You loving it yet
 

·
Premium Member
Joined
·
1,737 Posts
I will be looking in to it for anyone who has a v8 might be a little trickier since I own the v6, but i will do my best.
Still waiting on the V8 update for the torque delay. My dealer knows I am dying for it, so hopefully they let me know as soon as it's available. Since I first asked in March, it's always been "just a couple more weeks". I'm told they're working on it, but....
 

·
Registered
Joined
·
274 Posts
would you happen to know the Calibration ID: and the Calibration Verification numbers of your ECM and TCM

Perhaps it was on a previous Repair Order or If you have a scan tool you can view ECU information
 
61 - 80 of 86 Posts
About this Discussion
85 Replies
31 Participants
Rover19
RangeRovers.net Forum
We’re a community forum to discuss and assist on issues with every Range Rover model. Sign up if you have a question, answer or to meet like minded individuals
Full Forum Listing
Top