RangeRovers.net Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My fiancé' and I both have 2018 RRS models. Both of use have had the same issue where everything on screen looks correct but theres no audio. No music or phone playing in the vehicle. She said that she turns the car off and it corrects itself pretty much that way (even restarted the car at a red light), but I had to pull the back fuse for the infotainment to correct mine. This can't be a coincidence if both of us are getting the same no audio issue. She said it's happened to her several times while mine only happened this one time so far. Thoughts?
 

·
Registered
Joined
·
75 Posts
Happens sometimes on my 17 as well. Just have to wait for it to come back next time you start the car. If you let the system completely power down after shutting it off it should be back on the next cycle. I think its up to 60 seconds after shutting off the car that you have to wait for the system to completely power down. No fuse pulling should be required.
 

·
Registered
Joined
·
1,046 Posts
Happened to my 2016 a few weeks ago. Just driving fine and then all of a sudden the sound goes out. Screen looks fine etc. Changed sources and nothing worked. Wasn't until I turned the vehicle off and turned it back on once I got home that it started working again, and no problems since.
 

·
Registered
Joined
·
21 Posts
I had a similar audio issue on my 2018 RRS. I took the vehicle in for that and a few other issues and the dealer loaded some software updates that have pretty much addressed the problem with no further loss of audio for an extended period. I have momentary audio cut outs that may last a few seconds (infrequently) but the main issue was addressed with the updates.
 

·
Registered
Joined
·
3 Posts
Same issue on my 2018 RRS. It happened at a light after the car behind me got a bit too close and the parking sensors went off. After that no audio for the rest of the drive home. Stopped at a light to turn the car on and off and that didn't work . Waited a few hours and it worked fine. It's been in the shop since last week (already in twice) because of this and the dual monitor issue.

I bought it used (only 482 miles) and was told the previous owner traded it in for a full size. I also found out that the previous owner complained about all these things when he turned it in. Nothing disclosed to me though.

This is my 2nd RRS, and I love it but this is really turning sour fast.
 

·
Registered
Joined
·
1 Posts
My fiancé' and I both have 2018 RRS models. Both of use have had the same issue where everything on screen looks correct but theres no audio. No music or phone playing in the vehicle. She said that she turns the car off and it corrects itself pretty much that way (even restarted the car at a red light), but I had to pull the back fuse for the infotainment to correct mine. This can't be a coincidence if both of us are getting the same no audio issue. She said it's happened to her several times while mine only happened this one time so far. Thoughts?
My fiancé' and I both have 2018 RRS models. Both of use have had the same issue where everything on screen looks correct but theres no audio. No music or phone playing in the vehicle. She said that she turns the car off and it corrects itself pretty much that way (even restarted the car at a red light), but I had to pull the back fuse for the infotainment to correct mine. This can't be a coincidence if both of us are getting the same no audio issue. She said it's happened to her several times while mine only happened this one time so far. Thoughts?
I got the same problem but it happens a lot 2018 rrs
 
1 - 8 of 8 Posts
Top