RangeRovers.net Forum banner

1 - 10 of 10 Posts

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
OK, I have a strange one for you all.

So now that my RRS Autobio has 56,800 miles on him in less than a year , I brought it in for an alignment, oil change, tire rotation, a clunking sound on right front ( Lower control arm replaced) , and bluetooth wouldn't connect with iPhone X 11.4 50% of the time automatically. So they did software updates ( 6.6 hours labor service invoice says) , all the other stuff. Now today I had a 2.5 hr drive to Greenwich, CT and cruise set to 75mph, on a conference call , I reach down and adjust the drivers temp from 66 to 68 and the seat automatically started moving forward , and tilting the backrest forward. . I reached down and stopped it , moved it back to where I had it.

I get off the conference call, say " hey siri check messages " and the HVAC fan goes to high and the sunroof tilts open .

I was crossing into CT so as anyone knows CT is a twilight zone so anything is possible lol...

I called my dealer they said " oh , ummm bring it back we have had another one do that, We have to reload the whole vehicle it will take a few days though "
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #2
An update bahahaha , sitting in traffic on 95 north in Orange CT , I reached down in stop and go traffic to turn on sat radio , touched the screen and it went blank and now I have no dash screen & no infotainment screen . It’s like the truck is off . But the engine is running , in gear . Wonder if my brake lights are working

Getting off next exit to pull over and shut it down . See if it resets .


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #3
Update #2

Have Speedo screen , no infotainment or nah screen ....


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #4
116 miles with AirPods on and 9 miles from home the infotainment system turns back on and I have audio and Bluetooth again ...... what the ______ ?


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #5
Update .... day 3 of being at the rover hospital , software didn’t reload properly , waiting for “ main ECU , infotainment ECU , body control ECU , and 2 wiring harnesses per Land Rover escalation service support , bring the enterprise rental back to us, I’ll get you a rover to use “

They took a CPO full-size supercharged off the lot and put a dealer plate on it . Aka this is going to take awhile .....




Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #7
Update .... oh wait no update ... called dealer on my way home from the office and got “ we’re still working on it , waiting for 3 more parts , we also did 2 TSBs , our hope is to have it back to you by Thursday end of day “

On the bright side , I got to drive a full size and its making me want to order a L405 SVA sooner than planned grrrrrrr


Sent from my iPhone using Tapatalk
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #8
Update, just called the dealer after leaving them alone all week and I was told that the master tech was finishing up putting trim pieces back on and then it was going to get detailed inside and out because of all the finger prints all over the dash, dust and dirt from the construction going on. " You should have it back to you by 4pm, I can have someone drop it off to your house if you'd like? " He said all TSBs have been done while they were waiting for parts, software updates were completed and tested, they also re-did the 4-wheel alignment again due to replacing bushings after removing upper control arms. may the rover gods be with me hahaha
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
91 Posts
Similar issue just started with my ‘15.5 HSE. Drivers seat started moving while driving. Only would go backwards while all the other adjustments worked fine. Started to get dangerous as I’m only 5’10”. Tried to adjust again and the forward/back wouldn’t work at all. Then it starts moving in very small increments when you hit the button to adjust. Parked for a while, operated as normal, then started doing it again. Checked for anything that could be jammed in the track causing the issue, but couldn’t see anything. Has now happened a third time in 2 weeks. Sometimes works as normal, other time nothing moves, then starts moving in small increments. Had a software update a few months back so wondering if that could be the issue. Looks like it need to go to the dealer. First gremlin though in 3 years of ownership.
 

·
Registered
2016-2018 Range Rover Sport
Joined
·
145 Posts
Discussion Starter #10
Their software is def crapppppola mine has been OK since they “forced software updates “ to every single module possible .

Now on the wife’s SVR , she said She’s heard crackling when on calls , and it’s telling her randomly the air suspension is inoperable and sometimes won’t turn on sound system but looks on the screen that it’s playing music can fast forward , reverse , change play lists just nothing from speakers . Then lets it sit for hour or so and it’s fine.


Sent from my iPhone using Tapatalk
 
1 - 10 of 10 Posts
Top