Range Rovers Forum banner
1 - 3 of 3 Posts

· Registered
2016 Range Rover Sport
Joined
·
224 Posts
I have 275/55/20 tires fitted on my 2016 V8 Dynamic on the factory 20 inch rims. No problem with rubbing. The brakes are clear. My tires are BFGoodrich T/A KO2.
 

· Registered
2016 Range Rover Sport
Joined
·
224 Posts
Thanks! We're the 275 factory? Sorry just haven't seen that particular size.

I'm looking at the hakkas, which would mean the width would be slightly different than yours for some reason. TIA
The 275 are not factory. Factory is 255 on 20 inch rims. My tires are 1 inch taller in diameter and fit fine. The increased width isn't a problem either. I think that 265/50/20 will easily fit.
 

· Registered
2016 Range Rover Sport
Joined
·
224 Posts
Hello all

Which offset are you guys driving?
I had 265 50 20 before and last Friday I mounted 255 55 20 Continental TS850P on my RRS.
The rims are 9.5x20" with an offset of 53 (aftermarket, non OEM rims)
We saw, that they are quite near the whole suspension

Therefore.. anybody driving the same offset?
Perhaps this will also answer the first question

We have seen something like kind of "scratches" - see attached picture. Sorry, I don't know the exactely wordening in Englisch
Are these "scratches" normal?

I summer I have mounted the style 508 22" stealth rims

Thanks a lot
Regards
I'm sorry that I cannot answer your question. I bought 20 inch factory rims to replace the 21 inch rims the car came with. I have no rubbing with 275/55/20 BFGoodrich T/A KO2 tires.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top