RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I have a 2014 RRS HSE - single owner/purchased new - now has 83k miles. The CEL came on and started flashing and the vehicle died. It would restart but ran very rough and the light continued to flash. We had it towed to a local shop and he’s saying the timing chain needs to be replaced. The quote is $3,700.

Questions - is 83k miles really enough miles to require a new timing chain? I have a 2005 LR3 with 140k miles that has not required this. Could it be something else?

Is $3,700 a good price?

Thanks in advance
 

·
Premium Member
Joined
·
1,326 Posts
Yes, the 3.0 and 5.0 are very prone to timing issues. It seems as though you did the 10k-15k mile oil change intervals.

$3700 is a fair price, I would only go with them if they are a Land Rover/Jaguar shop.

This job is not for a first timer.


The 4.4 AJ41 in your LR3 is bullet proof, known for it.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Thanks for the reply. The shop is a local independent shop. The nearest Land Rover dealership to me is 70+ miles away.

I’m thinking about getting this fixed and trading it for a 2019 RRS SC Dynamic. Any long term reliability issues with that engine?

And you are correct. The LR3 has been bulletproof - really have enjoyed it.
 

·
Registered
Joined
·
340 Posts
So 10-15K service is not recommended???
I'm changing my oil every 5K miles with 5w20 Full Synthetic Castrol Engine Oil... Dirty oil and not running a full oil sump with near Maximum Oil Level stresses the engine and it's components.

At 83K miles, our 14' Rover has either a stretched timing chain, worn tensioners/guides, overhead cam gears, actuators, etc... She's going in for service tomorrow. Someone on here said that 13' and 14' model Rovers have a (Technical-Service-Bulletin) from the Factory out about this known issue. Can anyone point me in the right direction to find it. Using the search button only told me about 10' to 12' model years having this problem but the 5.0V8Supercharged in years 13' and 14' was absolutely mentioned by a Mod as having the same common problem. Thanks in advance...

-Ham
 

·
Registered
Joined
·
340 Posts
What was the outcome on your timing chain? I thought mine was the timing chain but nope... it was a slung rod! Previous owner went too long in between oil changes and let the oil level get too low the Rover shop foreman master mechanic said. I believe it. I'll change the oil every 4,500 miles myself regularly!
 
1 - 6 of 6 Posts
Top