RangeRovers.net Forum banner

1 - 2 of 2 Posts

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
50 Posts
Discussion Starter #1
After having it at the dealership for 2 weeks for an HVAC motor replacement, I just got my baby back. However, within days details on the workmanship made me question quality of the job.

As I got in, I noticed few minor scratches on the lacquered inserts. I know removing the dash to replace the motor is a major job, so I just left that alone. As I was getting out the car at home, I noticed that the driver side kick panel under the dash, is not exactly flush with the rest of the dash. There is about 4mm gap there. The top and bottom glove box doors are not aligned properly making it a bit difficult to open/close. Lastly, the tech left a screw in the dash that rolls around as I get on and off exit ramps.

Lack of quality made me wonder about the rest of the job, so I plugged in my GAP tool and scanned the car for codes. The HVAC ECU is not showing any faults. However, when I tried to read live values from some of the sensors, they were showing N/A.

Interior temperature N/A
Right air blend actuator position N/A
Left air blend actuator position N/A
External nitrogen oxide sensor N/A
Sensor supply voltage 5.0V
External ambient temperature 66.2F
Windshield interior air temp 203F
Windshield interior surface temp 554.0F

The car was parked, idling and the outside temperature seemed correct. What worries me is the lack of interior temperature and seemingly high windshield interior surface temp.
When I go to the dealership to ask them to adjust the dash, can I mention the GAP tool and the values I read, or should I just ask them to test the internal temperature sensor?

Thank you
M
 
1 - 2 of 2 Posts
Top