RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2010-2012 Range Rover Sport
Joined
·
7 Posts
Discussion Starter #1
Vehicle ran great until the other morning, Now vehicle cranks over continuously when start button is pushed but will not start. Had it towed to the local LR dealership but they were no help. Had several misfire codes and a low fuel rail pressure code. Dealership said fuel pressure was good and wanted several thousand to continue diagnostic tear down. Brought the vehicle home. After further troubleshooting, i found that if i disconnect the battery and let it sit for 10 minutes or so, after reconnecting the battery, vehicle will start right up but will only run for about 2 seconds and immediately shut off. If i try pushing the start button again, it will just crank over with no start. Repeat disconnecting the battery, let sit and then reconnect and it starts right back up but shuts down every time.

Any idea whats happening here, i have spark and fuel pressure at start up, battery is good. Seems to be an electrical issue.
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
7 Posts
Discussion Starter #3
Check for a possible bad ground, a bad ground can cause havoc maybe try a new battery too.
Thanks, Ill check for that. I did find during troubleshooting that I do not have consistent spark. I put a new battery in it and cranked it over with one plug wire pulled. No spark, after cranking for approximately 3 seconds, vehicle suddenly started and I had all kinds of spark on the plug then. Only ran for about two seconds and lost spark again.
 
1 - 3 of 3 Posts
Top