RangeRovers.net Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
This is happening often...


...and I am wondering if anyone has had the same problem what was done to fix it.

I know for sure that when this happens:
1) I am stopped or parked
2) Usually side cameras, but sometimes the front
3) and each and every time this has happened, I have been extremely hungry

Any Ideas?
 

·
Registered
Joined
·
382 Posts
LMAO! :lol:

Popcorn, I love it! That was really clever and funny!

Cheers,
:thumb:
 

·
Registered
Joined
·
14 Posts
Discussion Starter #4
--thank you.

I figured out the cameras only go out when the range rover is sideways - regardless whether it is leaning towards the right or the left.

when i park on a street or somewhere that is not flat, i get blue screen.

off to the shop...
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
petrolburner said:
--thank you.

I figured out the cameras only go out when the range rover is sideways - regardless whether it is leaning towards the right or the left.

when i park on a street or somewhere that is not flat, i get blue screen.

off to the shop...
One has to wonder if you lived in Kansas if you would have ever noticed this problem.
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
Updated troubleshooting document and new Special Service Message (new harnesses / camera leads available) for 2010+ owners with surround camera system still experiencing the dreaded BSD.

Reference SSM45634
Models LR4
Range Rover Sport
Title Proximity Camera System Diagnosis aid
Category Electrical
Last modified 30-Nov-2010 00:00:00
Symptom 205000 Electrical Accessories
Content

Note
New type camera lead and additional overlays now added for Range Rover Sport and Discovery 4/LR4

Issue:
Requirement for additional information for the diagnosis and repair of the Proximity Camera System fitted to10MY onwards Land Rover vehicles.

Cause:
Information previously unavailable.

Action:
Use the attached document to aid in the diagnosis and repair of the Proximity Camera System.
In the event there is a need to replace a damaged Coaxial cable, Overlays are now available and are listed below.


Range Rover Sport and Discovery 4 / LR4

LR025329 Front left camera LHD C3342 to C3359L
LR025330 Front right camera LHD C3340 to C2674L
LR025331 Front left camera RHD C3342 to C3359R
LR025332 Front right camera RHD C3340 to C2674R
LR025333 Right door camera LHD and RHD C3343 to C0460
LR025334 Left door camera LHD and RHD C3344 to C0460
LR022555 Module to HLDF Interconnect C3338 to C1185
LR025527 Engine compartment LHD C3392 to C2675
LR025528 Engine compartment RHD C3392 to C2675
LR025529 Engine compartment LHD C3393 to C3360
LR025530 Engine compartment RHD C3393 to C3360

Range Rover Sport ONLY

LR025338 Module to rear camera C3346 to C2788T
LR025525 Front door C3351 to C3504
LR025526 Front door C3353 to C3503
LR025534 Front bumper C3395 to C3349
LR025535 Front bumper C3394 to C3347
LR022554 Module Interconnect to HLDF C1185 to C3443T
 

Attachments

·
Registered
2010-2012 Range Rover Sport
Joined
·
56 Posts
christian said:
Bonjour
Hello
Thank you for your reply.
The garages have kept French and Belgian respectively 20 and 15 days because he can not find the fault.
They changed the left front camera, but it is rather an issue on fiber optics in the beam, He put a repair kit on the beam left front of the camera but the problem persists. the problem is likely later in the beam !!!!!!
Yep, my dealer had my car for over a week while they ordered new cameras, then changed all the cameras to no avail. In the end I gave them the service bulliten posted on this website and they ordered new harnesses and fixed it. Hilarious...not. BTW the blue screen has reappeared briefly a couple of times since...usually after I've been through the carwash......but generally its fine now.

oh yeah, I have no idea where the harnesses run but they left oily fingerprints on my headliner :x

Megan
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
110 Posts
Funny. I've been experiencing the same problem on my MY2011 HSE.

Exact same cameras too. (top left, bottom right, and occasionally the rear view one)

Dealer replaced the entire wiring harness to no avail, the problem persists. Dealer now tells me he has no clue what to do about it.

Since you all are arguably more intelligent than the combined workforce of my LR dealer, does anyone have an idea on what to do about this?

I do also have a hunch that it is humidity related as it is definitely worse on a rainy/snowy or carwash day!
 

·
Registered
Joined
·
325 Posts
Amsterdave said:
Funny. I've been experiencing the same problem on my MY2011 HSE.

Exact same cameras too. (top left, bottom right, and occasionally the rear view one)

Dealer replaced the entire wiring harness to no avail, the problem persists. Dealer now tells me he has no clue what to do about it.

Since you all are arguably more intelligent than the combined workforce of my LR dealer, does anyone have an idea on what to do about this?

I do also have a hunch that it is humidity related as it is definitely worse on a rainy/snowy or carwash day!
after having run into this thread, i used the camera function and sure enough the front driver side cam has the blue screen and sometimes the passenger side flickers blue.

it did it on a sunny/dry day.

i'll have it looked at or maybe i'll wait till they get a real solution released?
 

·
SUPER MODERATOR
Joined
·
979 Posts
Wow - thought I was the only one - I've been seeing this intermittently on various cameras, mostly at night. This is the backup camera shot from last night.



And great video BTW, well done!

UPDATE - Sorry, I found this post through a search and didn't realize it was in a Sport thread, even after seeing the video, ha.
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
110 Posts
michaeltw said:
UPDATE - Sorry, I found this post through a search and didn't realize it was in a Sport thread, even after seeing the video, ha.
Yeah, baby! Us youngsters have got leather stitching too nowadays! ;)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #12
I spoke with the service manager (Gregor) at Rancho Mirage, CA, about this when I took mine in for its 1st service. He and their master tech knew right away what needed to be done. They had ordered the parts, rewired all the cameras, put in a new harness, and it all seems to be working. I haven't had the blue screen since, but I have noticed that the camera(s) will slowly flicker -- or kind of a fast fade out/in...almost like when the screen of your iPhone dims just before it sleeps, but then comes back to normal brightness. The screen doesn't go completely dead or blue, just slightly flickers.

At least I can use them, and there is a lot less rim-steel on the curbs now.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #13
umbertob said:
Updated troubleshooting document and new Special Service Message (new harnesses / camera leads available) for 2010+ owners with surround camera system still experiencing the dreaded BSD.
...and thank you umbertob!! I referred to this when I took mine in for service.
 

·
Registered
Joined
·
325 Posts
so is umberto's service bulletin official LR release? i want to present it to my service advisor and want to make sure i minimizes chances of push back.

sounds like if you're still getting the blue screen or remnants of it they didn't do the job thoroughly.

why is this system so fragile?
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
It's officially TSB # LTB00367 in North America now, so your dealer should pay more attention if you still suffer from Blue Screen Of Death on one or more of your surround cameras, and you bring it up the next time you check in for service. Depending on the number of harnesses that may require replacement, that's a bear of a job! Look at the estimated labor hours in the list - and you just know that LRNA doesn't overestimate. :shock:
 

Attachments

·
Registered
2010-2012 Range Rover Sport
Joined
·
110 Posts
Mine was at the dealer since Monday morning as well, just picked her up and had a 30m drive without any of the camera blues... first time ever... I'm still cautious until it has been a little longer, but it seems to have been resolved or at least greatly improved!
 

·
Registered
Joined
·
43 Posts
mine had the same problem.. dealer took care of it in two days.
 

·
Registered
Joined
·
325 Posts
just make sure you guys check around for scratches and other GOLLY GEE WHIZZLE!

they have to tear out your interior to get this work done.
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
56 Posts
THEROK said:
just make sure you guys check around for scratches and other GOLLY GEE WHIZZLE!

they have to tear out your interior to get this work done.
So that explains why my headliner had a oily fingerprints on it after I had this repair done. Absolutely disgraceful. :x

Megan
 
1 - 20 of 41 Posts
Top