RangeRovers.net Forum banner

1 - 15 of 15 Posts

·
Registered
2010-2012 Range Rover Sport
Joined
·
260 Posts
Discussion Starter #1
Hey Guys/Gals,

I waited unitl my car had some decent milage before I wrote up some issues of my 2010 RRS HSE.

-2010 RRS HSE Build Date MY 7/09
-2,100miles

1) First day of ownership car had a "Hood Open" warning sign
--Went into the dealer and they replaced the microswitch in the hood

2) Windows One Touch Up on the rear windows don't work sometimes
--Yet to be addressed

3) Navi System / Stereo freezes and you can't change tracks or do anything other than turn up or down the volume. Car needs to be restarted and then goes back to normal. So far this has happened twice
--Yet to be addressed

4) Transmission has software issues...when coming to a stop sign the car will downshift like normal but then when ready to accelerate it will just rev as if the car was in nuteral and then after a second will kick into gear.
--Yet to be addressed

5) Electronic parking brake has a fault. Sometimes when parked and ready to engage parking brake the cars TFT screen will flash yellow and display "Parking Brake Fault". When this happens the cars parking brake is engagted and WILL NOT release parking brake until the car is restarted.
--Just started happening 12/26/2009 and is yet to be addressed.

6) Steering wheel RARELY remembers its saved setting. This drives me nuts!
--yet to be addressed.

So far that is all I've noticed, some of these are completely unacceptable for a $65k+ car. I will be taking it into service hopefully in the next week or so.

Cheers,
James D.
 

·
Registered
Joined
·
318 Posts
TriGem2k said:
Hey Guys/Gals,

I waited unitl my car had some decent milage before I wrote up some issues of my 2010 RRS HSE.

-2010 RRS HSE Build Date MY 7/09
-2,100miles

1) First day of ownership car had a "Hood Open" warning sign
--Went into the dealer and they replaced the microswitch in the hood

2) Windows One Touch Up on the rear windows don't work sometimes
--Yet to be addressed

3) Navi System / Stereo freezes and you can't change tracks or do anything other than turn up or down the volume. Car needs to be restarted and then goes back to normal. So far this has happened twice
--Yet to be addressed

4) Transmission has software issues...when coming to a stop sign the car will downshift like normal but then when ready to accelerate it will just rev as if the car was in nuteral and then after a second will kick into gear.
--Yet to be addressed

5) Electronic parking brake has a fault. Sometimes when parked and ready to engage parking brake the cars TFT screen will flash yellow and display "Parking Brake Fault". When this happens the cars parking brake is engagted and WILL NOT release parking brake until the car is restarted.
--Just started happening 12/26/2009 and is yet to be addressed.

6) Steering wheel RARELY remembers its saved setting. This drives me nuts!
--yet to be addressed.

So far that is all I've noticed, some of these are completely unacceptable for a $65k+ car. I will be taking it into service hopefully in the next week or so.

Cheers,
James D.
Nice review. Quite frankly I'm a little disappointed at some of the issues the '10 owners have been having. I was hoping to hear that everything has been good and that the RRS reliability continues to get better.

Some 2 years ago I was in the market for an SUV for my wife. I desparately wanted an '03 full size but was horrified after reading the reliability issues (we ended up with a GX470). I then began reading about the RRS and how much more reliable they were than the earlier RR's hence the reason I have one now. I really don't want LR to go in the wrong direction.
 

·
Registered
Joined
·
36 Posts
TriGem, I hear you on the issues and have experienced some of what you decribe. My vehicle is Mfg Date 09/09. It's in the shop as I type this.

TriGem2k said:
Hey Guys/Gals,
2) Windows One Touch Up on the rear windows don't work sometimes
--Yet to be addressed

3) Navi System / Stereo freezes and you can't change tracks or do anything other than turn up or down the volume. Car needs to be restarted and then goes back to normal. So far this has happened twice
--Yet to be addressed

6) Steering wheel RARELY remembers its saved setting. This drives me nuts!
--yet to be addressed.
I have experienced each of the above. As for the rear window, try resetting by pulling up and holding for 5 secs, the window should go all the way up and reset. This *should* re-enable the auto-up feature. This happened to me at the dealership the day I was picking up my vehicle and the sales rep reset it for me doing what I just described. As I understand it, LR designed it so that you can have the option of not having the rear windows go auto up if you have kids.

Ditto on the Nav system. Does your nav system's preferred language setting revert to English (UK) no matter what language setting you chose... e.g. I select English (US) and after restarting the car, it always reverts to English (UK). This is a known issue and is addressed in a TSB.

Steering wheel on my vehicle *usually* remembers the saved setting. Still, on occasion, it will move to a position "close" to what was saved, but somehow can't get itself to get there exactly. I have to push the Memory buttons I have programmed to nudge it the final few degrees. Yeah... annoying.


TriGem2k said:
Hey Guys/Gals,
1) First day of ownership car had a "Hood Open" warning sign
--Went into the dealer and they replaced the microswitch in the hood

4) Transmission has software issues...when coming to a stop sign the car will downshift like normal but then when ready to accelerate it will just rev as if the car was in nuteral and then after a second will kick into gear.
--Yet to be addressed

5) Electronic parking brake has a fault. Sometimes when parked and ready to engage parking brake the cars TFT screen will flash yellow and display "Parking Brake Fault". When this happens the cars parking brake is engagted and WILL NOT release parking brake until the car is restarted.
--Just started happening 12/26/2009 and is yet to be addressed.
Have experienced none of the above.


TriGem2k said:
... some of these are completely unacceptable for a $65k+ car.
Agreed. LR North America just sent me an online customer sat survey for the vehicle. I intend to be frank.

Honestly, to be at the bottom of Consumer Reports for so many years in a row and given the posts on this forum, I would think someone would light a fire at LR.
 

·
Registered
Joined
·
67 Posts
Interesting write up - I'm curious to see how I make out with mine.

While I basically agree that it is frustrating to spend good money on a car to have these irritating issues come up, I've had a variety of issues with new cars over the years starting back in 1991 (my first new car). This spans 13 vehicles from Ford, Chevy, Volvo, Volkswagen, Jeep, BMW Porsche & Audi (and now Land Rover!). Depending upon the car, I've spent less and I've spent more than $65k (in today's dollars) and can say that I have yet to meet a car company that's got it figured out. Sometimes I wonder how car companies stay afloat with the amount of warranty work I've had on my cars over the years.

Keep us posted and I'll be sure to detail any issues - usually shared knowledge helps take care of these things over time!
 

·
Registered
Joined
·
318 Posts
tbone89 said:
Honestly, to be at the bottom of Consumer Reports for so many years in a row and given the posts on this forum, I would think someone would light a fire at LR.
Doesn't matter people still buy them.
 

·
Registered
Joined
·
16 Posts
Man that really sucks you have so many issues already. Ive had my 2010 supercharged sport for about 1500 miles and a month and its been good so far.
Altho I just realized they put the wrong RPM gauge on it so im going to have to call the dealership. Indead of my gauge going up to 8 or 9000 rpm's it only goes up to 6000 rpm and shows the redline at 4k rpm. Electrically and mecanically the vehicle has been flawless so far(knock on wood) and i couldn't be happier.
 

·
Premium Member
2006-2009 Range Rover Sport
Joined
·
5,175 Posts
stackedu said:
Altho I just realized they put the wrong RPM gauge on it so im going to have to call the dealership. Indead of my gauge going up to 8 or 9000 rpm's it only goes up to 6000 rpm and shows the redline at 4k rpm. Electrically and mecanically the vehicle has been flawless so far(knock on wood) and i couldn't be happier.
:shock:

Check under the hood, you may have accidentally been shipped a TDV8 you lucky devil. :D
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
260 Posts
Discussion Starter #8
TBone,

I feel you about the car being in the shop. The first month I owned the car it was in the shop for exactly 15 days for the tranny and some recalls that had not been done at port when the car arrived in the states.Once I got it back is when I noticed most of my listed issues and that is why they have yet to be taken care of by the dealer. I am TRYING to enjoy the car a little bit before it goes back in to the shop to get these things taken care of.

What exactly is your car in the shop for right now?

I'll keep everyone posted on what becomes of these once the car goes in for the work.

My biggest thing that I hope that the MY 2010's get is the updated TFT screen. If it's not something that is avaiable as an upgrade you better believe I am going to raise hell out of every little nick pick issue this car has and they better make me darn happy for pullin a fast one on the early adopters.

-Seano, I hope you don't experience any issues with yours brother! At least SOMEONE will enjoy their car more than the dealer enjoys working on it!

UK- You're absolutely right about people will be buying them anyways. You know what though, I was so pleased the LR when I bought my sister a 2008 RRS SC back in 2008 that I would have never thought the 2010s would have this many issues. Oh well, the rule stays true...first year productions of any make and model will have problems.

-Stack, let us know if anything ones up with the 2010 SC. There aren't too many of you guys around. When I was looking to buy my 2010 the 3 major dealers in LA had the SC's at 10k ABOVE sticker!!! That made me stick to the HSE real quick! :D
 

·
Registered
Joined
·
16 Posts
gooseyloosey said:
stackedu said:
Altho I just realized they put the wrong RPM gauge on it so im going to have to call the dealership. Indead of my gauge going up to 8 or 9000 rpm's it only goes up to 6000 rpm and shows the redline at 4k rpm. Electrically and mecanically the vehicle has been flawless so far(knock on wood) and i couldn't be happier.
:shock:

Check under the hood, you may have accidentally been shipped a TDV8 you lucky devil. :D

maybe this is a stupid question but what is a TDV8?
 

·
Registered
2010-2012 Range Rover Sport
Joined
·
260 Posts
Discussion Starter #10
stackedu said:
gooseyloosey said:
stackedu said:
Altho I just realized they put the wrong RPM gauge on it so im going to have to call the dealership. Indead of my gauge going up to 8 or 9000 rpm's it only goes up to 6000 rpm and shows the redline at 4k rpm. Electrically and mecanically the vehicle has been flawless so far(knock on wood) and i couldn't be happier.
:shock:

Check under the hood, you may have accidentally been shipped a TDV8 you lucky devil. :D

maybe this is a stupid question but what is a TDV8?
Thats the Diesel version in the rest of the world
 

·
Registered
Joined
·
36 Posts
Ukraine Range said:
tbone89 said:
Honestly, to be at the bottom of Consumer Reports for so many years in a row and given the posts on this forum, I would think someone would light a fire at LR.
Doesn't matter people still buy them.
True. True.
 

·
Registered
Joined
·
16 Posts
ha, its definitly not diesel since i fill it with premium and get a great 12mpg mainly highway. I do enjoy blowing cars off the line at every redlight which probably brings the MPG's down lol
 

·
LIFETIME CONTRIBUTOR
2006-2009 Range Rover Sport
Joined
·
11,013 Posts
TriGem2k said:
Hey Guys/Gals,

2) Windows One Touch Up on the rear windows don't work sometimes
--Yet to be addressed
Sorry to resurrect an old topic, but a software fix is now available from LRNA for the above issue on 2010s. TSB enclosed.
 

Attachments

·
Registered
2010-2012 Range Rover Sport
Joined
·
260 Posts
Discussion Starter #14
Thanks Umbertob!
 

·
Registered
Joined
·
14 Posts
Wow, sounds like some things never change!

I have a 2006 RRS S/C Limited, and had 3 of those problems over time. Hey look on the bright-side, at least your RRS didn't cost 82k! : )

The e-park fault was a HUGE problem for me. I was literally stuck on 2 out of town trips and had to get towed because of it.

Good Luck
 
1 - 15 of 15 Posts
Top