RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
451 Posts
Discussion Starter #1
Some new symptoms for my MY 2010 L322 HSE

Started getting the Gearbox Fault message on occasion.
It reads the following fault:
P0915 Gearshift position – circuit range / performance
On occasion, the warning of stability control not working and some other relevant warnings. I forget the exact language.
Then the Bonnet open warning kept popping on and off while driving
I either clear it or stop and restart and it goes away. While active, truck seems to be in 3[SUP]rd[/SUP] gear only.
I had my battery and alternator checked. Battery seemed a bit weak, Alternator fine as per Autozone.
I replaced the battery.
Still having the issues. Now my power windows’ auto up function is no longer working.
After on line research, I’ve found the following possible causes:
Gearbox sensor
ABS wheel speed sensor
Stop light switch attached to the pedal
Angle steering sensor
Bad ground wires in the sills or elsewhere.
I also found these other codes lurking:
U0126 Lost communication with steering
U0402 Invalid data received from transmission control module
B12FE Fan
U0416 Invalid data received from vehicle dynamics control module
P0850 Park / neutral switch input circuit

Anyone care to take a swing at this?
Much appreciated.
DC
 

·
Registered
Joined
·
451 Posts
Discussion Starter #2
Apparently, the loss of the auto up for the windows is unrelated. It was from the battery swap. That’s been reset.
Anyone care to take a stab at the gearbox fault issue?
 

·
Registered
Joined
·
451 Posts
Discussion Starter #3
I should have left my model year off of my signature. At least I would have gotten some sort of reply.
Thanks anyway, gents.
 

·
Registered
2010-2012 Range Rover MkIII / L322
Joined
·
102 Posts
I should have left my model year off of my signature. At least I would have gotten some sort of reply.
Thanks anyway, gents.
Too true Dave! I wish that I could help, though I have not encountered similar issues... yet.

Best of luck finding a solution. It never hurts to check your grounds and cables for continuity.
 

·
Registered
Joined
·
451 Posts
Discussion Starter #5
Too true Dave! I wish that I could help, though I have not encountered similar issues... yet.

Best of luck finding a solution. It never hurts to check your grounds and cables for continuity.
Thank you.
 

·
Administrator
Joined
·
27,802 Posts
Why on earth would you leave your model year off? That makes no sense at all. We ask for model year and model so folks can give accurate answers based on your rig. 2010 was the first year for 5L platform. There are many difference in your rig when compared to 4.2/4.4 generation.
 
1 - 6 of 6 Posts
Top