RangeRovers.net Forum banner

1 - 6 of 6 Posts

·
Registered
2010-2012 Range Rover MkIV / L405
Joined
·
3 Posts
Discussion Starter #1
It seems I have a faulty TPMS module. Light just randomly comes on and off, no,warning message. Where is the TPMS module located for 2009 Sport.

Thanks!
 

·
Banned
2013-2015 Range Rover Sport
Joined
·
139 Posts
it is above your head. where the cabin lights and sunroof controls are. Pop that panel, TPMS module is right behind it.
I had the same problem, there are numerous articles where people suspecting sensors themselves but it is almost always a module.
 

·
Registered
2010-2012 Range Rover MkIV / L405
Joined
·
3 Posts
Discussion Starter #3
I popped the cover off and didn't see it behind the panel? Any chance it would be somewhere else?
 

·
Registered
2007 Range Rover Sport Supercharged
Joined
·
8 Posts
I have the same problem. Replaced all sensors and it didn’t fix the problem.

I would like to find out where tpms module is and it’s part number so I can order new one
 

·
Registered
2011 Range Rover Sport HSE Lux & 2017 Range Rover Evoque HSE Dynamic
Joined
·
1 Posts
Hello all. New member to the forum. I have had a 2011 Range Rover Sport HSE Lux for three years now. I do not recall the spare tire TPMS alert coming on when you start the vehicle, but it then goes away after a few seconds. I have take my spare tire off and there is no TMPS sensor in it and also inflated to 60 psi. I tried having a local mechanic hook up his device to the OBD port to change TPMS to "no spare" and did not work. I have searched the forum and see nothing specific about this, but surely could use some expert advice. This alert is aggravating. Thank you!
 
1 - 6 of 6 Posts
Top