RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
3 Posts
Discussion Starter #1
When driving the A/C emits cold air and warm air intermittently. While idling I can also hear the fan under the hood blowing very loudly when the air goes from cool to warm (I assume this is the fan associated with the compressor). About three months ago I used a DIY A/C recharge after to the A/C went completely hot. It remained cool for a few weeks but eventually started with the intermittent hot and cold air. What I notice most is that the air is just not getting very cool. Before these issues, I could see the frost coming out of the vents but not anymore. I am worried that maybe I overcharged the system when I used the DIY A/C recharge or even worst I am concerned that the compressor is going bad. If anyone can point me in the right direction it would be greatly appreciated.

2009 Range Rover L322 HSE
 

·
JACK'S GRANDAD
Joined
·
9,244 Posts
Go get it vacuumed down and recharged with the right amount if no leaks found. Before you screw something up that costs a lot more.
There is a lot of guessing going on, but not a lot of facts. The fact of the matter is, you have no idea how much 134 is in the system right now, and until you do you are purely guessing
Martin
 

·
Registered
Joined
·
385 Posts
There’s a good chance you over charged the system. Assuming you bought the refill kit with the gauge, measure the charge, following the directions, and discharge from the shrader valve if required, just don’t let a Global Warming looney see you doing it.
 
1 - 3 of 3 Posts
Top