RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
19 Posts
Discussion Starter #1
Today both upper and lower glove boxes have stopped working. There's no click from the switch up or down. Is it possible to have put this 2008 l322 into some Valet setting? I have read the manual and googled to death this issue to no avail. I saw that fuse 43 supplies the so thought it might of blown. So much huffing n puffing managed to force the lower GB open, but all the fuss were good. There is 12volts onto the release connection, and whilst pushing the button the 12v remains on. So for me it's either a relay somewhere or its in Valet mode. Any ideas?
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
19 Posts
Discussion Starter #2
Would like wiring diagram for 2008 l322 of anyone has it. Seen older versions of wiring diagrams ie 3.0td but it doesn't show an electrical release but a cable release. I think the security lock when locked with the key fob has not unlocked itself.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
19 Posts
Discussion Starter #3
All sorted. Found that a signal from the tilt/Generic module was stopping the operation of the GB. This is an inhibit signal when the car is locked. So removed the switch from the dash. Snipped the signal wide and it's working. Would love to find out why the Inhibit signal was being driven but just glad to get the GB working again.
 

·
Registered
Joined
·
11 Posts
All sorted. Found that a signal from the tilt/Generic module was stopping the operation of the GB. This is an inhibit signal when the car is locked. So removed the switch from the dash. Snipped the signal wide and it's working. Would love to find out why the Inhibit signal was being driven but just glad to get the GB working again.
Mine has stopped working too. How did you fix?
 
1 - 4 of 4 Posts
Top