RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I purchased my 2007 RR Sport SC w/ 45,795 miles on it in Nov 2017- great car and love it!

Week after I bought it, red suspension light came on so I brought in to dealer. They did diagnostic on it, determined it was a bad battery and replaced it no charge- car runs fine since then!

Driving from Orlando to Jacksonville yesterday, light comes back on w/ warning to turn off engine and take in for service ( same warning I got first time it happened.) Car was running fine and I only had 50 miles to go so continued home (I'm a female, know nothing about cars and didn't want to be stuck on side of 95 by myself!)

Called dealer this morning and was told couldn't get me in til next week. I don't have another car to drive, not sure I should be driving w/ red light on (service dept said it would be ok to drive????) and not sure what to do.

I don't raise or lower the suspension ever, just leave those controls on the settings they were on when I purchased the car. I basically just drive it like a regular car! Not even sure if they are on the right settings for normal driving.

Any suggestions on what I should do, what might be the cause and solution and how much is it going to cost to fix?? Thanks!
 

·
Registered
Joined
·
91 Posts
Are there messages on the dash? If so, what does it say? It could be the air suspension or the dynamic response system (anti roll bars). I am sure someone more knowledgeable will offer more advice soon.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
No messages on dash except when light first came on. It said turn off engine when safe and have car serviced.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
UPDATE: took car to dealer this morning w/out appt. Red suspension light on for 30 min drive. Turn off car when I get there, service advisor gets my info, tells me will have to leave it and will work it into schedule, might take a week! Then she turns car back on to see red light, it doesn't come on after she takes for a test drive. Tells me whatever was wrong has corrected itself, just needed to go through another drive cycle. Car has been running normal since light came on yesterday. I drove home and light did not come back on so hopefully it is fine.

i am a bit skeptical though, it just doesn't seem right that light would be on yesterday/ today and now it is off. Has this happened to any of you? Is it normal to correct itself? I'm happy light is off but just wondering if car is in need of maintenance- dealer says no as long as light is off!
 

·
Registered
Joined
·
134 Posts
Initial diagnosis of battery may mean it's an electrical issue. I would be leaning toward a loose battery cable right now! Had that once, and my 2008 RRS went crazy, but all fine after cable tightened. Loose battery cable or ground would trigger some type of false warning.
 

·
Registered
2006-2009 Range Rover Sport
Joined
·
227 Posts
30 minutes seem about enough for the ACE low fluid level sensor to kick in. If your suspension works (seems you didn't check it, as you mention never rising up or lowering the car with the buttons), you most likely have a leak from the active antiroll bar system.
 
1 - 7 of 7 Posts
Top