RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone,
First post so forgive me for being greedy with 2 queries......

1) Electrical - Something strange has happened over the last couple of weeks. After unlocking the car, climbing in and switching the ignition on, as soon as its switched on the hazard lights begin to flash constantly. Pressing the hazard switch cancels them. Then after the car is started it becomes apparent that the interior light is on constantly. Pressing the switch turns that off and then it works as it should.
Has anyone had anything similar?

2) Mechanical (I think) - Noticed the other day whilst out on a decent drive that I had a metallic/squeaking/chattering noise coming fro somewhere under the car but very sporadic. Noticed it occurred mostly between 40-50mph regardless of whether the car is accellorating or free wheeling. Since then I reckon could be something brake related as when the brake pedal is pressed the noise stops immediately. Discs and pads look ok. Anyone have any ideas on this one too?

cheers, Ian
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
About problem 1, I have exactly this every 2 weeks or so, I think it's either the car trying to communicate some mislock/alarm error or just a bug. Couldn't relate it to anything I do although it sometimes seems to be related with opening/closing the boot...
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
237 Posts
You know, I'm really not that optimistic. Sometimes the CD/mp3 sound locks after answering a phone call and doesn't resume (needs restart). Or the front parking sensor beep doesn't stop until you remove the key. Other times the dash screen starts blinking (usually at twilight). My heated seat doesn't work but issues no fault signals. I guess I'll have to live with this. Someone said don't fix the minor problems on a RR otherwise major ones appear!
 
1 - 4 of 4 Posts
Top