RangeRovers.net Forum banner

1 - 3 of 3 Posts

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
80 Posts
Discussion Starter #1
Hello,

I recently purchased 2006 RR SC. The front lighter is not working. I checked fuses and they are good. I need to access wiring for lighter to diagnose problem. I have searched for directions to remove center console, but I haven't had any luck finding instructions for console similar to my car. I'm open to any suggestions.

Thanks,
Lou



https://goo.gl/photos/eagEpqeZdGZRQcDN8
 

·
Premium Member
Joined
·
1,309 Posts
Hello,

I recently purchased 2006 RR SC. The front lighter is not working. I checked fuses and they are good. I need to access wiring for lighter to diagnose problem. I have searched for directions to remove center console, but I haven't had any luck finding instructions for console similar to my car. I'm open to any suggestions.

Thanks,
Lou



https://goo.gl/photos/eagEpqeZdGZRQcDN8
I have the same issue with no power there, I'll be keeping my eye on this post.
 

·
Registered
2006-2009 Range Rover MkIII / L322
Joined
·
80 Posts
Discussion Starter #3
Today I removed the center console to access the Lighter. The lighter is not getting power... I tested the leads that attach to lighter with with multi-meter. I also checked fuse #2 in the dash, and fuse #1 in rear with multi meter. I did notice the rear fuse was 15amp, and I believe the manual specifies a 20amp.

Pry up on Back of Shifter Surround:

20161229_164401_zpsyyrf0d5k.jpg

Remove the 4 torx Screws under shifter surround
20161229_164348_zpsg7jyjhiq.jpg

Remove Cup holder by pulling straight up, and remove two torx holding center console.
20161229_164714_zpsa1oebqwe.jpg

Lift straight up on center console to get access to lighter from side.

20161229_172813_zpstmjx9f6o.jpg

I discovered the green plastic surround on my lighter was broken during previous service, and I was able to push the lighter up from the bottom. When I was going through the paper work from previous owner. I noticed that the dealer had addressed the complaint that lighter wasn't working the end of October. The tech must have been in a huge hurry because some of the trim clips were missing. They must have fallen off, or possibly were broken during the repair, but they were left off.

I haven't had any luck figuring out why the lighter isn't getting power, but I'm open to suggestions.

I also measured the trim clips, and went to auto zone where I found a similar clip for jeep. I'll post picture of RR Clip.

20161229_185903_zpsdih20tql.jpg 20161229_185835_zpsudjlxfs1.jpg
 
1 - 3 of 3 Posts
Top