RangeRovers.net Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hi,
Just installed Proud Rhino lift rods front and rear. Rear end is totally jacked up in the rear, but the fronts are on the bump stops. I get the messages Extended Mode, also more often Reset height if clear of obstacle.I am baffled. It's an easy job, but I'm lost.
 

·
Registered
09’ Black RRS, 12’ Sand RR HSE
Joined
·
11 Posts
Maybe a recalibration/reprogramming would do the job, since the car now rides on a different height than earlier before installing the lift rods kit, the system might read the extra height as an extended mode.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
So if you reverse the directions, they work. I'm not kidding. It had long rear, short front. Actually had the car taken to the shop. They switched them and it was fine. No re calibration. Even the shop kept a copy in case another one comes in with the same issue.
 

·
Registered
09’ Black RRS, 12’ Sand RR HSE
Joined
·
11 Posts
Gla
So if you reverse the directions, they work. I'm not kidding. It had long rear, short front. Actually had the car taken to the shop. They switched them and it was fine. No re calibration. Even the shop kept a copy in case another one comes in with the same issue.
Glad to hear that it’s fixed then, good luck.
 

·
Registered
Joined
·
38 Posts
Been thinking of doing the same or using 4DCan software to re-calibrate the suspension height a bit higher - Is there a benefit either way to doing it programatically vs rods (Johnson or Rhino)

Did you also reset the bushing ride height for the control arms at the same time? Does the new ride height change the caster/camber/tow?
 
1 - 5 of 5 Posts
Top