RangeRovers.net Forum banner

1 - 6 of 6 Posts

Registered
Joined
16 Posts
Discussion Starter #1
Just picked up a 05 with 113k it was fine the 50 miles home I changed the brake pads and wear sensors it was still fine the next day we had heavy rain then the abs and hdc light came on and that was a week ago now it comes on and goes out intermittently. I went to the auto store got 100 scanner and nothing says no codes found. Please someone give me some advice
 

Registered
Joined
222 Posts
Check the wiring connections of your abs sensors at all 4 corners. Spray some of those electric contact cleaners. While you were replacing the wear sensors perhaps you disturbed the abs wiring harness in the area leaving them kinda vulnerable to moisture/water. Water must have gotten in thus causing intermittent continuity.
 

Registered
Joined
16 Posts
Discussion Starter #3
You talking about the wires in the little black box? Will that case hdc inactive message also?
 

Registered
Joined
222 Posts
Yes that box. Abs malfunction will always trigger hdc inactive. However hdc inactive can be triggered but other things. In your case start by resolving the abs fault.
 

Registered
Joined
222 Posts
Check the wiring connections of your abs sensors at all 4 corners. Spray some of those electric contact cleaners. Water must have gotten in thus causing intermittent continuity.
what I said above. You are looking to get rid of water or moisture in the connections inside the 4 black boxes. That's where I would start.
 
1 - 6 of 6 Posts
Top