RangeRovers.net Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
2 months ago, exhaust system dropped to replace all 4 O2 sensors. Minor crack observed and welded on driver side CAT.

Past 2 weeks, started getting P0463 & P2A03 codes. The upstream sensors have been swapped between driver and passenger side and P2A03 code remains consistent (Bank 2, Sensor 1). Have noticed a slight "rumble" when revving the engine.

Also tried with the new O2 sensor, same result.

Performed ECU reset, codes back after 30 miles. Unfortunately, inspection is due this month.

At this point, any ideas would be welcomed as I was hoping to avoid having to schedule an appointment at the dealership.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
291 Posts
Searching for P2A03 seems to have a lot of hits for exhaust leaks. If you have a smoke machine, I would try smoking the exhaust system to see if there any leaks, especially that you originally found a cracked cat.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
1,947 Posts
maybe the weld that was done has a crack next to the new weld
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Thank you for the feedback. Took RR to exhaust shop. Small hairline crack around seam of driver's side CAT. $30 and 20 minutes later, cleared all codes and drove 15 miles to my normal repair shop. All codes greens to proceed with annuals emissions and state inspection. Passed the inspection.
 
1 - 4 of 4 Posts
Top