RangeRovers.net Forum banner

1 - 7 of 7 Posts

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
17 Posts
Discussion Starter #1
Howdy. I recently bought this truck and have been very pleased overall. 118,000 miles on the clock and it purrs like a kitten. Has the original suspension, etc etc. But, the turn signals are being very weird. The rears always work, but the fronts take turns working and not working. Mostly on the left side, but sometimes on the right. Sometimes, they all work perfectly. Once in a while, the "check side light" warning will flash on the dash, but not always. They seem to work a bit better just after starting out, when it is colder. They will blink fast as if a bulb were out, but then, once in awhile, they will blink normal speed. Anyone have this happen? Could it be the turn signal relay cutting out when it gets warmer, or something like that? I haven't checked the emergency flashers, but probably should. Thoughts would be appreciated. Thanks.
 

·
Premium Member
Joined
·
1,306 Posts
Well what have you done? It has check side light so maybe a failing bulb. Possibly a cheap failing LED, maybe even a resister in the mix!

You tell us..


Sent from my iPhone 7 Plus using Tapatalk Pro
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
17 Posts
Discussion Starter #3
Tomorrow I will change the bulbs in front and the sides. Remember, they all work now, occasionally, but, bulbs are cheap, so I'll start with that. If that doesn't cure it, what would be your advice to check next? Thanks!
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
1,941 Posts
make sure to look at the side repeater bulbs use Deoxit D100 spray on all of the bulb connections, google search will find it Deoxit D100 spray
NOTE the D5 is a cleaner spray the D100 is full strength
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
32 Posts
I had a bulb that was good but the contact in the socket (metal part that touches the bulb) was worn and dirty. I cleaned it up, pulled the contact forward for better contact, and that allowed the light to work again.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
17 Posts
Discussion Starter #6
I ordered some deoxit 100 and will go through all the light sockets as soon as it arrives. What is particularly weird is that the "check sidelight" warning is on, but both sidelights work. When I started the truck this morning, all was well until about 5 minutes into the drive. Then, as usual, the signal light indicator started flashing fast. Sometimes, it will flash fast and then slow down to regular speed! Seems like something somewhere is only making an intermittent connection.
 

·
Registered
2002-2005 Range Rover MkIII / L322
Joined
·
1,941 Posts
you can turn the bulbs 180 degrees in each socket the deoxit will restore the conductivity of the contacts
 
1 - 7 of 7 Posts
Top